[mythtv-users] interlace issue on TV?

Daniel Kristjansson danielk at cuymedia.net
Sat May 2 15:20:28 UTC 2009

On Fri, 2009-05-01 at 18:35 -0400, Tom Dexter wrote:
> On Fri, May 1, 2009 at 10:14 AM, Paul Gardiner <lists at glidos.net> wrote:
> > Udo van den Heuvel wrote:
> >>
> >> Tom Dexter wrote:
> >>>>>>>>
> >>>>>>>> At the start of this topic I explained how the VIA XvMC setup at is
> >>>>>>>> this point.
> >>>>>>>
> >>>>>>> Select "Interlaced(x2)" as your deinterlacer.
> >>>>
> >>>> As primary or backup?
> >>>> I can't find this deinterlacer in the list.
> >>>>
> >>> I did notice when I set mine up that the new deinterlacer didn't show
> >>> up when XvMC is set as the decoder.  I use either ffmeg or libmpeg2 so
> >>> it made no difference to me.  I don't know if that's by design or not.
> >>>  Paul may be able to answer that.
> >>
> >> Thanks, interesting observation as I do use XvMC, as posted earlier.
> >> Paul? Can I fix this?
> >> Or is it teh patch?
> >
> > Oh might be the patch. I use ffmpeg too, so I hadn't noticed
> > Interlacedx2 not appearing with XvMC.

Software deinterlacers will not work with XvMC. XvMC does not allow
you to do anything with the decoded stream other than to selectively
show the first, second or both fields. Showing the first field
corresponds to the onefield deinterlacer. Showing the first then
the second field corresponds to bobdeint (implemented differently
than bobdeint for software decoding). Showing both fields corresponds
to no deinterlacing.

-- Daniel

More information about the mythtv-users mailing list