[mythtv-users] Need ./configure help.

Johnny jarpublic at gmail.com
Fri Mar 27 19:27:09 UTC 2009

On Fri, Mar 27, 2009 at 3:17 PM, Mike Adolf <mlnx at mho.com> wrote:
> Trying to install (first time) MythTv 0.21 on Ubuntu 8.10 from a svn fixes
> download. I have been following the MythTv-HOWTO.pfd document and believe
> that I have installed the prerequisits.  However, when I run ./configure,
> I get the following errors:
> -------------------------------------
> funit-at-a-time is required for inlining of functions that are only called
> once (warning)
> You must have the Lame MP3 encoding library installed to compile MythTV.
> (fatal)
> -----------------------------------
> Don't don't know what funit-at-a-time is and I have lame 3.98 installed from
> Synaptic.
> Mike

Is there a particular reason you are compiling from source? If this is
your first time installing mythtv and you don't have a compelling
reason to compile from svn you may be better off and find things go
much smoother if you just install the precompiled packages from the
repository. If you want to have up to date builds from the .21-fixes
branch then you can try the mythbuntu repository. They have weekly
builds of .21-fixes. Use the UK repo though there has been some
problem with the US repo not updating for some reason. You can start
by installing mythbuntu-control-centre and from in there you can type
of mythtv setup you need (ie BE only, FE only, or combined BE/FE), and
it will take care of installing and configuring the right packages for


More information about the mythtv-users mailing list