[mythtv-users] Testing HDMI

Geoffrey Leach geoff at hughes.net
Tue Mar 24 22:44:30 UTC 2009

On 03/23/2009 09:29:20 PM, James wrote:
> > My new frontend/backend is based on the ASUS P5N7A-VM which 
> provides
> > HDMI output (and much else) using the Nvidia nForce 730i. Video is
> > excellent at 1080p through the HDMI output connector to a Sony
> Bravura
> > LCD.
> >
> > Here's the problem. There's no audio. The required ALSA drivers are
> > provided by Fedora 10 and the sound chips are recognized. Earphone
> > connection works fine.
> >
> > I know the HDMI cable works. However, neither piece of gear that 
> was
> > once on either end of the cable is around any more, so I have no 
> way
> of
> > determining which end of the cable is not working.
> >
> > Any suggestions?
> What is the output of:
> aplay -l
**** List of PLAYBACK Hardware Devices ****
card 0: NVidia [HDA NVidia], device 0: ALC888 Analog [ALC888 Analog]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: NVidia [HDA NVidia], device 1: ALC888 Digital [ALC888 Digital]
  Subdevices: 1/1
  Subdevice #0: subdevice #0

> aplay -L
    HDA NVidia, ALC888 Analog
    Default Audio Device
    HDA NVidia, ALC888 Analog
    Front speakers
    HDA NVidia, ALC888 Analog
    4.0 Surround output to Front and Rear speakers
    HDA NVidia, ALC888 Analog
    4.1 Surround output to Front, Rear and Subwoofer speakers
    HDA NVidia, ALC888 Analog
    5.0 Surround output to Front, Center and Rear speakers
    HDA NVidia, ALC888 Analog
    5.1 Surround output to Front, Center, Rear and Subwoofer speakers
    HDA NVidia, ALC888 Analog
    7.1 Surround output to Front, Center, Side, Rear and Woofer 
    HDA NVidia, ALC888 Digital
    IEC958 (S/PDIF) Digital Audio Output
    Discard all samples (playback) or generate zero samples (capture)

FWIW, iec958 is un-muted via alsamixer

More information about the mythtv-users mailing list