[mythtv-users] New HD HomeRun problem

Bob Sully rcs at malibyte.net
Wed Mar 4 06:16:38 UTC 2009

R. G. Newbury wrote:
> Bob Sully wrote:
>> Jay Broussard wrote:
>>> On Tue, Mar 3, 2009 at 9:39 AM, Bob Sully <rcs at malibyte.net> wrote:
>>> Check the Silicon Dust homepage and see if your power supply has been
>>> recalled: http://www.silicondust.com/hdhomerun/power
>>> There are a lot of problems attributed to that.
>>> Jay
>>> This (or something very similar) happened to me recently. I had no
>>> problems getting a windows PC to record off the HDHR, but no joy on
>>> my Mythbox. In the end, removing the HDHR tuners from Myth and
>>> adding them back in fixed it for me. Of course, now I have to redo
>>> all of my channel assignments, but at least the HDHR works now.
>>> Justin
>>> Then, make sure that the router has not changed the IP address of the
>>> hdhr.
>>> Make sure that everything, including the channel standard is properly
>>> set on the hdhr....
>>> Most likely reason is that the router changed the IP of the hdhr. If
>>> you
>>> can, reserve the hdhr's IP address by tying it to the MAC, since there
>>> is no easy way to contact the hdhr under linux if the IP address keeps
>>> changing.
>>> If you cannot reserve an address, then reduce the allowed DHCP served
>>> range to ONE address, and let the hdhr have it.
>>> This does mean that you have to use static for everything else.
>>> Geoff
>> OK -
>> Tried power-cycling the router - no joy (even a hard reset and re-set-up
>> didn't change anything).  I don't think it's the IP address; I believe
>> the
>> HDHR has had the same IP addy for quite some time (  I
>> can't
>> really shut my DHCP server down to one address, as I have people coming
>> in
>> here all the time with laptops, and I need a working DHCP server.
>> What if it had changed?  How would I get Myth to find it?  Since the
>> config utility can find it using the serial number, and Myth HAS the
>> serial number, shouldn't Myth be able to find it no matter which IP it's
>> on?
>> Next, tried removing all of the capture cards, then replacing them in
>> the
>> same order.  That didn't work either.  The QAM section of the pcHD5500
>> works fine, though, so the "in the clear" video source I'm using appears
>> to be OK.
>> Rebooted the Myth BE/FE box before, didn't matter, will try again after
>> a
>> long download finishes up.
>> SiliconDust DOES say my power brick needs replacement, so they'll be
>> sending a new one (thanks, Jay!).  While I'm waiting for it to show up,
>> any other ideas?  I find this really odd, since it was working fine last
>> Friday, but not last night, and nothing else has changed.
>> Thanks for the help thus far - Bob
> Ah HAH!
> Try 'iptables -F' and then
> 'hdhomerun_config discover'
> Sometimes the firewall gets borken and mungs things.
> I have those lines in my mythbox' rc.local to ensure that the hdhr can
> be seen by the mythbox. Really screwed with my head for a while, that
> the &9$%&$%#$^&*(* hdhr would not work properly!
> But it was, actually. The fault was at the mythbox end.....
> Geoff

Hi, Geoff -

No change.

[mythtv at vader: ~]$ sudo iptables -F
[sudo] password for mythtv:

[mythtv at vader: ~]$ hdhomerun_config discover
hdhomerun device 101299CD found at

Bob Sully - Simi Valley, California, USA

More information about the mythtv-users mailing list