[mythtv-users] Fedora 11 and lirc

Harry Orenstein holists at verizon.net
Fri Jun 26 00:54:01 UTC 2009

On Thursday 25 June 2009 11:53:41 am Jarod Wilson wrote:
> On Jun 25, 2009, at 11:26 AM, Tom Dexter wrote:
> > On Thu, Jun 25, 2009 at 10:13 AM, Jarod Wilson<jarod at wilsonet.com>
> >
> > wrote:
> >> Some misc lirc notes for Fedora 11 users:
> >>
> >> 3) lirc_serial appears to be broken. I swear it worked last I tried
> >> it, but
> >> its been a while. For the record, I think lirc_serial is rather
> >> grotty code,
> >> and everyone should stay away from it and use something usb-based
> >> instead. I
> >> still intend to look at it and get it fixed though.
> >
> > I have vehemently disagree with that statement, and I think it's
> > seriously misguided advise to posting, especially without any
> > explanation.
> Um, "is rather grotty code" *was* my explanation. Seriously. Have you
> *looked* at the lirc_serial code?
> But if you insist, how 'bout these for further explanation:
> - requires disabling the standard serial port driver
> - no auto-loading when receiver is connected
> - next to nil device type auto-detection (see multitude of modparam
> options)
> - requires directly polling pins on the serial interface, not
> interrupt driven
> - hard-coded such that is only works on traditional com1/com2, can't
> be used with a serial add-on card or a usb-serial adapter
> > I've used lirc_serial on countless machines long before
> > I used MythTV...going back over seven years.  I don't recall ever
> > having an issue with it.
> >
> > I've been using it on my current MythTV frontend for two years now
> > under Gentoo over more kernels than I can count...currently on 2.6.28.
> My original mail said the code was nasty, not that it didn't work (in
> the non-Fedora 11 release kernel case, anyway). I'm quite aware that
> it works for a lot of people. Doesn't change the fact that the code
> and the way it operates are craptastic.
> > Seems to me that most of the lirc problems I read about here are with
> > USB.  For me, the remote was one of the easiest things to get working
> > on my MythTV system.
> I've seen more than plenty folks having problems with both lirc_serial
> and any number of usb-based receivers. To put it quite bluntly though,
> there are a lot of users out there that don't know wtf they're doing
> to begin with.
> I can drop an lircd.conf in place, plug in a supported usb receiver,
> start lircd up, and it Just Works. No dicking around with the serial
> port, no manual module loading, no modparams, etc.
> I stand by my statement that lirc_serial sucks.


I hope you don't mind if I ask a related question.  When I upgraded to 0.8.5 
on Fedora 10 the init.d entry was renamed and I decided to go from a custom 
init.d config to the standard.  In order to do this I can use all the standard 
configs (init.d and sysconfig) as you indicated above.  The only issue is that I 
needed to add an entry to /etc/sysconfig/modules to load the lirc_i2c module.  
My old init.d config loaded it explicitly, so adding the modules entry is 
effectively the same thing.  You indicated above that you don't have to do any 
manual module loading.  Other than the modprobe.conf alias entry for lirc_i2c 
(or whatever module you use), what causes your lirc module to load?  I am 
using lirc with my PVR-250, which may differ from using lirc with a usb remote.  
Any tips would be appreciated.


-- Harry O.

More information about the mythtv-users mailing list