[mythtv-users] Fwd: LiveTV not starting .... not sure if it's permissions or firewall or something else.

Marc Tousignant drayson at net1plus.com
Thu Jun 25 22:55:51 UTC 2009


I asked about that a week or two ago, and I can't remember seeing any

As this box is a my router,fileserver, network controller e.t.c.. I
can't change the hostname or IP as it will screw everything. 


However, it does seeem okay ... apart rom live tv .. 

here is the console output from mythfrontend... when trying to start
livetv .. something about program 0???

  Resource id:  0x4000cb
2009-06-26 07:43:23.839 Connecting to backend server:
(try 1 of 5)
2009-06-26 07:43:23.840 Using protocol version 40
2009-06-26 07:43:23.900 TV: Attempting to change from None to
2009-06-26 07:43:23.900 Using protocol version 40
2009-06-26 07:43:25.100 GetEntryAt(-1) failed.
2009-06-26 07:43:25.100 EntryToProgram(0 at Thu Jan 1 10:00:00 1970) failed
to get pginfo
2009-06-26 07:43:25.100 TV Error: LiveTV not successfully started
2009-06-26 07:43:25.100 TV Error: LiveTV not successfully started
2009-06-26 07:43:25.128 TV: Deleting TV Chain in destructor
2009-06-26 07:44:08.587 Deleting UPnP client...

On Thu, 2009-06-25 at 21:54 +0200, Jarle Thorsen wrote:
> 2009/6/25 sonofzev at iinet.net.au <sonofzev at iinet.net.au>
>         Hi Folks
>         I've moved my backend (with DB) to my home router/file server
>         box.. .
>         I'm nearly there (the tuners show up in system status and can
>         tune frequencies
>         from setup...).. however Live TV won't start... I have tried
>         both from the
>         frontend box .. and also a remote X session to the backend via
>         my laptop (the
>         backend is headless so I am using remote X via SSH to access
>         the mythtv-setup gui...)
>         Firstly I have changed the permissions on my recordings folder
>         to mythtv:users
>         and have given everyone write permissions.. However, in the
>         system status menu it
>         still shows unknown for the amount of available drive space. I
>         even tried chmod
>         777....
>         I am wondering if this still may be a permissions thing... or
>         possibly firewall..
>         I have allowed TCP traffic on ports 3306 (Mysql), and the 2
>         mythtv ports (6533
>         and 6534 from my LAN??? can't remember the exactport as I'm at
>         work)... Should I
>         also be allowing UDP for the video stream, or is that over
>         another port?
>         Is there anything else I need to look at. I can send output to
>         console, or logs
>         when I get home...
>         Regards
>         Allan
> Moving a mythtv setup from one machine to another it is advisable
> to use the same hostname on the new computer as you did on the old
> computer. As far as I know the hostname is stored several places in
> the db and it can give you problems if you move the mythtv setup to a
> machine with different hostname.
> -- 
> Jarle Thorsen


What does your backend say when this happens? 

More information about the mythtv-users mailing list