[mythtv-users] No OSD in LiveTV

Marc Tousignant drayson at net1plus.com
Thu Jun 25 13:54:20 UTC 2009

Ok, I wasn't entirely awake last night when I sent the log excerpts.


Working log: Playback of recorded video:



Nonworking log: Watching LiveTV:



I noticed that both of them have a line

VideoOutputXv: Chromakeying not possible with this XVideo port.

But it should not be using chromakey as the OSD Rednerer type. I am using
ia44blend for anything with a resolution of 1280x720 or higher.

 In the working version this only shows up once, in the non working it shows
up twice. Only reason I can think of this is because when I first load into
LiveTV I have an OSD popup telling me which source I am watching "1:


In the non working one however the first time it is seen this line is
followed by

VideoOutputXv: Ack! Disabling ChromaKey OSD


The second time it is followed by

VideoOutputXv: ProcessFrameXvMC: Tried to reuse frame but failed

VideoOutputXv: ProcessFrameXvMC: Called without frame

VideoOutputXv: ShowXvMC(): No ftarame to show


Here is another log.


 In this one I started in DVB on an HD channel (no OSD but I did see it for
a split second before video came up, and in color???, this is ia44blend)

switched to a SD channel on an IVTV card (OSD worked, this is chromakey)

switched back to a DVB HD channel (no OSD, this is ia44blend)

then to a DVB non HD channel  (OSD worked, this is chromakey)

and back to a DVB HD channel (no OSD, this is ia44blend)


Anyone else seeing this sort of issue or run into it before?




-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://mythtv.org/pipermail/mythtv-users/attachments/20090625/5856ead7/attachment.htm>

More information about the mythtv-users mailing list