[mythtv-users] No HDMI audio

Jim Stichnoth stichnot at gmail.com
Wed Jun 24 20:46:25 UTC 2009

Hi Peter,

On Wed, Jun 24, 2009 at 11:29 AM, Peter
Brouwer<pb.maillists at googlemail.com> wrote:
> Hi Jim
> See my earlier mails.
> Kernel 1.0.18a works for me! I used the 1.0.19 utils that I downloaded the
> source for and compiled myself.

Very interesting to hear that the 1.0.18a kernel modules work for you.

> Fist check that the digital channels (hdmi) is not on mute via alsamixer
> tool. It seems to be on mute as default.

Alsamixer doesn't show anything specifically called "hdmi", but there
are 3 channels called "IEC958", "IEC958 Default PCM", and "IEC958 1".
I'm guessing that the first and third refer to HDMI audio and SPDIF
audio, but I'm not sure which is which.  No effect in unmuting various

> After setting up /etc/asound.conf make sure to set default in the audio
> setup in myth for both audio and pass through

Hopefully I can get this resolved outside of myth first, before jumping in.

> ----
> Earlier mails that bounced on the alias
> Hi Jim
> tried to reply via the alias but mailrelay refused my mails
> Here is a copy:
> Post 1
> Hi Jim
> What kernel modules have you loaded? Can you post a lsmod output?
> I had similar problems and I had the intel hdmi module loaded instead of the
> nvidia one.
> Disabled the intel one and rebuild the kernel. That solved it for me.
> Also check vi alsamixer if the hdmi digital output is muted or not.
> Also noted that the sound over hdmi with a strait connection to my tv did
> not work.
> Connecting it via my AV receiver was fine, that was want I wanted in the
> end, sound via av receiver, image on tv.
> Post 2
> To add a bit more info, kernel alsa version is 1.0.18a.
> Use the following /etc/asound.conf file
> pcm.!default hdmi:NVidia
> pcm.iec958 hdmi:NVidia

I can give that a try later today.

> I am using gentoo and use the alsasound file in /etc/init.d to set the save
> state at boot time.
> Used alsamixer to unmute the digital output and saved this state
> "/etc/init.d/alsasound save"
> All works fine now
> Post 3
> Hi Jim
> You seem to be missing the nvhdmi driver
> This is what I have loaded ( and it seems to work fine with alsa 0.18a!
> kernel module)
> snd_hda_codec_nvhdmi     1288  1
> snd_hda_codec_realtek   206220  1
> snd_hda_intel          15000  0
> snd_hda_codec          38552  3
> snd_hda_codec_nvhdmi,snd_hda_codec_realtek,snd_hda_intel
> snd_hwdep               4192  1 snd_hda_codec
> snd_pcm                45152  2 snd_hda_intel,snd_hda_codec
> snd_timer              13608  1 snd_pcm
> snd                    37432  6
> snd_hda_codec_realtek,snd_hda_intel,snd_hda_codec,snd_hwdep,snd_pcm,snd_timer
> snd_page_alloc          5240  2 snd_hda_intel,snd_pcm

I don't seem to have the nvhdmi kernel module anywhere on my system.
However, I see that it has been built in alsa 1.0.20.  So I guess I
will first try installing 1.0.20 kernel modules, and then dropping
snd_hda_intel in favor of nvhdmi.

> Also check you bios is there are specific settings to enable/disable hdmi
> sound.

There are.  There are separate settings for enabling/disabling onboard
audio (the plugs) and HDMI audio.  Both are enabled by default; I also
tried booting with only HDMI audio enabled, but with the same result.

> Regards
> Peter



More information about the mythtv-users mailing list