[mythtv-users] No HDMI audio

Allen Edwards allen.p.edwards at gmail.com
Tue Jun 23 17:01:07 UTC 2009

On Tue, Jun 23, 2009 at 9:54 AM, Jim Stichnoth <stichnot at gmail.com> wrote:

> On Tue, Jun 23, 2009 at 6:52 AM, Allen Edwards<allen.p.edwards at gmail.com>
> wrote:
> > A simple test is to set alsa up with
> >
> >   pcm.!default {
> >      type plug
> >      slave.pcm "hdmi"
> >   }
> >
> > and put a CD in and issue this command
> >
> > mplayer -cache 500 -cdrom-device /dev/cdrom cdda://
> >
> > Also, don't ignore settings in your TV.  It would be great if you had
> > another hdmi device to use to test the TV.
> Thanks.  I will try that in my alsa config (I might have already tried
> it, but it was 2am...).
> I tried a direct HDMI connection between the TV and the Dish VIP211,
> and video and audio were just fine.
> I tried connecting a Zotac ION box to the TV via HDMI, but they refuse
> to talk to each other, even at BIOS startup time.  There's another
> thread here about that, suggesting HDCP problems, so I can see that
> I'm in for even more fun.
> Jim

I hate HDCP.  I have to turn my projector on before my DVD player or the DVD
player won't work.  I am wondering if you can use DVI out of the computer
and just spdif into the TV so the TV thinks it is being driven by a computer
and won't care about HDCP.  You can use a DVI to HDMI cable or adapter.  I
have read that some TVs mute the sound if you put video in the HDMI input so
you might have to make some change for that.  There have been threads on
that on this list.

I don't know that this will work, but you might keep it in mind in case
other more straightforward ways fail.

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://mythtv.org/pipermail/mythtv-users/attachments/20090623/61e34bfc/attachment.htm>

More information about the mythtv-users mailing list