[mythtv-users] No HDMI audio

Jim Stichnoth stichnot at gmail.com
Tue Jun 23 09:24:24 UTC 2009

Sorry for yet another digital audio thread.

I can't get any audio whatsoever to go through my HDMI connection.
Here are some details of my setup:
  - Gigabyte GA-E7AUM-DS2H motherboard
  - MythDora 10.21 (kernel
  - alsa 1.0.20
  - nvidia driver 180.51
  - Vizio TV model VW32L

The alsa version is a little weird.  "yum list alsa\*" shows version
1.0.20-1.fc10 of alsa-lib.i386, alsa-lib-devel.i386, and
alsa-utils.i386, yet "cat /proc/asound/version" gives 1.0.18a.

I even went so far as to disable onboard audio in the BIOS setup,
leaving HDMI audio enabled.  Here are the results of aplay:

$ aplay -l
**** List of PLAYBACK Hardware Devices ****
card 0: NVidia [HDA NVidia], device 3: NVIDIA HDMI [NVIDIA HDMI]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
$ aplay -L
    HDMI Audio Output
    Discard all samples (playback) or generate zero samples (capture)

Alsamixer shows just one control, IEC958, and I have unmuted it.

No audio with Myth.  No audio with something like "mplayer -ao
alsa:device=hdmi -afm hwac3 1071_20090620215900.mpg".  No audio with
"speaker-test -D hdmi -c 2".  I tried following Allen's tips in
http://www.mythtv.org/wiki?title=AllensDigitalAudioHowto (but at 2:00
in the morning I'm not sure I tried every combination).  Pulseaudio
appears not to be installed except for pulseaudio-libs.

Interestingly, if I ctrl-alt-F2 to switch into a console window, aplay
says there are no devices.  I wonder why is that?

Any suggestions on how to proceed?  Does anyone have positive
experience with HDMI audio on this motherboard, the Gigabyte


More information about the mythtv-users mailing list