[mythtv-users] Hard hangs on 0.21-fixes with HVR-2250 - suggestion or similar experiences?

Matt Beadon matt.beadon at gmail.com
Mon Jun 22 19:22:30 UTC 2009

I'm running 0.21.20080304-1 from the Debian multimedia repo on a combined
BE/FE using Lenny.

I used to have a PVR-500 that worked perfectly then I added an HVR-1600 when
the comcast switched to mostly digital.  That setup worked pretty well
except my signal strength was not sufficient for good digital reception.

Long story short, I got my wiring redone to improve SNR so digital tv looks
good and swapped my HVR-1600 with a HVR-2250 since 1 digital tuner wasn't
enough and I'm short on PCI/PCIe slots.

In the past 2 weeks I've had about 4 hard locks, usually when the frontend
was idle.  Keyboard numlock, capslock etc won't toggle, the machine doesn't
respond over the network and strangest of all the display is frozen (but not
corrupted) showing the frontend.

I turned on logging on the backend and launched the frontend with:
mythfrontend -v important,media,audio,playback -l mythfrontend.log

However I'm not getting any indications in the logs (or the system logs)
what caused these hangs.  What I can see is that a single recording started
on the HVR-2250 at the time of the hang and that file was found to be
corrupted/missing upon restart.

I followed the instructions here for setup of the HVR-2250
http://www.linuxtv.org/wiki/index.php/Hauppauge_WinTV-HVR-2200 with the
addition of changing Max recordings to 1 (something I guessed applied to
each tuner in HVR-2250 since it applied to the HVR-1600).

http://www.mythtv.org/wiki/Hauppauge_hvr-1600#Configuration  -> Configure
the ATSC... -> step #6)

Any suggestions for increased log levels that might shed light on this?

Anyone else seeing similar problems with HVR-22X0?

Other than these incidents my HVR-2250 seems to work quite well but this
lack of stability is ruining WAF.  Any help is appreciated.


P.S. I noticed that most posting about the HVR-2250 are using firmware 1.0.2
for this card.  I'm using 1.0.3 since that's what came with the packages
when I downloaded them.  Worth reverting the firmware to 1.0.2?
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://mythtv.org/pipermail/mythtv-users/attachments/20090622/78083f32/attachment.htm>

More information about the mythtv-users mailing list