[mythtv-users] Zotac ION / no video using DVI/HDMI and nvidia driver

Bill Williamson bill at bbqninja.com
Thu Jun 11 01:55:12 UTC 2009

On Thu, Jun 11, 2009 at 8:06 AM, Nick F <nikos.f at gmail.com> wrote:

> On Tue, Jun 9, 2009 at 10:14 AM, Paul Gallaway<pgallaway at gmail.com> wrote:
> >> First, you can get a TTY by changing to one, which means your HDMI
> >> output is definitely working to that TV.
> >> Unless I missed it, the one thing you haven't mentioned is if your TV
> >> supports HDCP or not.
> >> Is there anything in the Zotac BIOS to turn off HDCP?
> >
> > Barring an obvious menu change, there does appear to be some trouble
> > with the set and 1:1 pixel mapping over HDMI, possibly HDCP related.
> > Read the thread on your TV set over at avsforum as the info is there
> > but it's going to take more time to find it than the 5 minutes I spent
> > looking. Apparently there is a possible solution posted but I gave up
> > looking for it (found lots of responses referencing it but no one
> > bothered posting a link). If it involves the service menu you will
> > probably have to request someone PM the instructions to you.
> > http://www.avsforum.com/avs-vb/showthread.php?t=1039018
> >
> > My next suggestion would have been to look at defining an EDID in your
> > xorg.conf or forcing a modeline  Both are discussed here:
> > http://www.gossamer-threads.com/lists/mythtv/users/372280#372280
> > If it's an HDCP problem then you are unlikely to get very far with
> > either of those methods.
> Thanks guys - a HDCP issue is certainly possible.  I see no way to
> turn it off on the ION within the nvidia settings available in
> xorg.conf, and I can't figure it out on the TV (and I've gone into the
> service menu using the instructructions from avsforums).  I have
> defined several EDIDs and forced modelines - X validates the ones in
> spec, uses them - but I get the blank picture syndrome (regardless of
> resolution).  What's really strange is that it's clearly not an
> electrical connection issue - because the same setup with the vesa
> driver (rather than nvidia) works just fine (but I can't use
> accelerated video which obviously doesn't work for the application).
> Last night in dispair - I took my system from the basement which
> drives the 1080p BenQ projector (which is an Atom 330 + a 8400GS
> nvidia board) and saw if that worked with my TV.  It works fine!  I
> thought that would be similar to the ION - being an Atom plus a VDPAU
> capable nvidia, using the same driver.
> I then took the troublesome Zotac IONITX and connected it to the BenQ
> - and it works fine!  So - for now I've just swapped them around. It
> doesn't completely solve my issue - since I wanted audio over HDMI -
> and my 8400GS has a DVI output, but not a HDMI.
> So - it appears there is something peculiar about my TV, and the ION.
> I've tried various drivers from the 180.x and the 185.x family - but
> maybe need to try a pre-180 driver to see if the behaviour is there as
> well (but then I wouldn't get VDPAU - which would defeat the purpose
> of the board, but at least narrow down the problem).
> If anyone knows how to fiddle with HDCP settings in the nvidia driver
> I would appreciate it, if that is indeed the problem. It certainly is
> the most logical at this stage.  The only good thing to come of this -
> is that I am now completely up to speed with modelines and xorg.conf!

I do not believe that linux supports HDCP.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://mythtv.org/pipermail/mythtv-users/attachments/20090611/6dbf1ccf/attachment.htm>

More information about the mythtv-users mailing list