[mythtv-users] Zotac ION / no video using DVI/HDMI and nvidia driver

Brad Fuller bradallenfuller at gmail.com
Tue Jun 9 01:12:17 UTC 2009

On Sun, Jun 7, 2009 at 4:54 PM, Nick F<nikos.f at gmail.com> wrote:
> I've got a strange problem which I've been beating my head against all
> weekend.  I received my new Zotac ion (A) board this weekend - the one with
> the Atom 330 and the external DC power supply.  I set it up no problem
> connected to my computer monitor (over HDMI) - everything worked - audio of
> HDMI included.  I was happy.
> I then moved it from my office to the family room where it will serve duties
> driving a 42" LCD 1080p (a Dynex DX-LCD42HD-09). I have had a mac mini
> (using Ubuntu 9.04 and 8.10 before that) driving the TV using a DVI to HDMI
> cable.  Everything was fine with the mac - except I wanted to use HDMI
> audio, and the mac couldn't play back high def h.264 and VC-1 from blu rays.
> When I connected the ION to the TV - everything went fine through the BIOS
> posting, and ubuntu splash - but when the picture was meant to come up at
> the login screen - nothing.  Just a black screen.
> I reinstalled Ubuntu 9.04 from scratch.  WHen it was using the vesa driver
> before installing the nvidia drivers- it was fine and could drive the LCD
> over HDMI.  The minute I switched to nvidia - same thing blank screen.
> (remember this worked driving 1080p with my computer monitor over HDMI).  I
> tried 8.10, I tried different versions of the nvidia driver -- even
> installing the nvidia .sh from the nvidia website - no dice.
> I extracted the modeline and put that into my xorg.conf.  Xorg.0.log showed
> the modeline being validated, but same thing - blank screen.  I reinserted
> the mac mini, and double checked the modeline the intel card in that was
> using.  Same thing - blank screen.  I tried other (lower) resolutions - same
> thing.
> I tried using the same DVI - HDMI cable I was using with the mac - same
> thing, blank screen.
> I tried using the VGA connection and the modeline I was using for my DVI
> connection - and get a wonderful 1920x1080 60p signal!
> So - now I'm very confused.
> The LCD TV appears to work - the mac mini drove it fine using its HDMI input
> The board seems fine and working with the nvidia drivers - when using my
> computer monitor rather than the LCD TV
> The modeline seems fine - the VGA input is happy with it
> I've been playing with every combination I can think to throw at xorg.conf
> and am deeply confused.  Do these two products when combined with the nvidia
> driver just not want to speak to each other?

like the other poster, I would check to see if your other video
outputs work. I know that the MX440 (and maybe another board, can't
remember) would not boot with S-Vdieo unless the device connected to
the S-Video was on. Even though xorg.conf was setup right, if nvidia
didn't see the S-Video device, it wouldn't output to it. I don't know
if it was the drivers or the hardware. This is a bit different than
your situation, still it might be that at boot the device is not
confirmed and so no video is sent out that port.

Brad Fuller

More information about the mythtv-users mailing list