[mythtv-users] Mythtvosd not working from backend?

Thomas Mørch tmorch at gmail.com
Mon Jun 8 12:19:45 UTC 2009

2009/6/8 George Mari <george_mythusers at mari1938.org>

>  Thomas Mørch wrote:
>> I have been fiddling with mythtvosd, but it fails when I run it from my
>> backend.
>> If I run mythtvosd from the backend, my frontend machine doesn't do
>> anything. If I use another computer on the network, it shows the osd. So
>> at
>> least the frontend is working.
>>  The backend serves as both myth backend, with a couple of receivers, as
>> well as mail, web etc. server, and firewall.
>> I have tried to disable the firewall (shorewall) clearing the netfilter
>> tables, but it doesn't help.
>> Any pointers?
> I use mythtvosd to display caller id information, as described in the wiki.
>  I have it setup on each frontend that I have, however, and I did not think
> it was possible to use it from the backend to "send" a message  to a
> particular frontend to be displayed on it's OSD.
> What is the command line you are using to do this?  Are you getting an
> error message when you say it doesn't work?
There is no errors, mythtvosd say that it send the UDP/XML packet, but
nothing happens on the frontend. And if I take my laptop, and use the same
mythtvosd command, the message show up on the frontend.

As far as I can see, mythtvosd makes an broadcast to all frontends on the
network, not just the one it is running from.

I have also tried to clear netfilter tables, just to be sure that it wasn't
the firewall that played some silly tricks on me. But it still doesn't work
from the backend..

/ Thomas
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://mythtv.org/pipermail/mythtv-users/attachments/20090608/37375a85/attachment.htm>

More information about the mythtv-users mailing list