[mythtv-users] no audio after Nvidia driver install

James Neff neffland at gmail.com
Sun Jun 7 13:59:46 UTC 2009


New to MythTV using version 0.21, MythBuntu distro.  kernel 2.6.28-11
Hauppauge 1600 model 1178 using cx18-0 v4l-cx23418-apu.fw
nForce 2 motherboard w/ onboard audio AC97
video source is DirectTv to analog in on my Hauppauge 1600 board.

First installed Myth audio was working.  Had problems getting remote
to work with the IR blaster.  Worked through that issue all the while
audio was working while I watched TV.  Installed the Nvidia
proprietary driver because I wanted to use s-Video out from my video
card (had been plugging video out from regular VGA to monitor until
now).  Moved the machine to the living room (rebooting of course) and
now audio doesn't work when I watch TV. Audio does work when I play
DVD from MythTV.

aplay -vv somefile.wav
does in fact play sound!

Currently setup:
audio output device:  ALSA:default
passthrough output device:  ALSA:iec958{ AES0 0x02 }
Max Audio channels:  Stereo
Upmix:  Active Simple
Enable AC3 to SPDIF passthrough: off
Enable DTS to SPDIF passthrough:  off
Agressive Sound Card:  off
Use internal volume control:  on
Mixer Device:  ALSA:default
Mixer Controls:  Master
Master Mixer Volume:  100
PCM Mixer Volume:  88
Independent muting:  off

This sound output does have 5.1 capabilities.  But if I choose 5.1 for
"Max Audio channels" then I still get no audio but see "Mixer unable
to find control Master 2"  and repeats for masters 2 through 5.  Also
get WriteAudio:  buffer underrun .

If I leave channels on stereo I get no errors in mythfrontend.log.

It is very well possible that I accidentally changed something while
going through the General setup during the install of the Nvidia
drivers.  It was late at night.

It is hard for me to troubleshoot when there are no error messages
which leads me to believe this is a configuration issue.

Thanks in advance,

More information about the mythtv-users mailing list