[mythtv-users] Trying to use upnp, weird issues

Mark J. Small msmall at eastlink.ca
Fri Jun 5 19:49:28 UTC 2009

On June 5, 2009, Brian Wood wrote:
> On Friday 05 June 2009 12:05:38 Mark J. Small wrote:
> > Hi everybody,
> >
> > I'm trying to use the upnp features of mythtv to serve my music and
> > pictures. I'm using the 0.21 packages from the stable tree of
> > debian-multimedia.org on a Debian Stable system.
> >
> > I've installed djmount on a separate machine, and it does not see any
> > upnp servers on my internal network.
> >
> > I've read the the ip address (not localhost), must be entered in to the
> > backend for upnp to work properly.  Well Mythtv-setup has the proper ip
> > address entered, but the setup->general screen in mythfrontend points to
> > localhost.  If I try to change this, then I can no longer connect to the
> > database, and the backend will not restart either.
> >
> > I've used nmap to check the standard upnp ports, but tcp 5000, 1900 and
> > udp 1900 are all closed.
> >
> > Does anyone have any advice?
> You need to have the real IP in both locations in your setup. I guess this
> means figuring out why things don't work when you set things up that way.
> I entered the real IP of a combined FE/BE machine in both locatons in the
> setup, once I did that the UPnP server function worked fine.
> Even if you could get the UPnP functions running with "localhost" you would
> still have a problem, because the URLs that your UPnP control point tried
> to go to would contain the localhost address, which would obviously not
> work.

So I'm trying to set the host to the real IP address in both locations, but 
when I do, I can't connect to the database anymore.  I get this:

QMYSQL3: Unable to connect
Database error was:
Access denied for user 'mythtv'@'debtest' (using password: YES)

where debtest is the name of my backend.


This really looks like a mysql problem now, but if I check the grants, I see 
mysql> show grants for mythtv@"%";
| Grants for mythtv@%                        |
| GRANT USAGE ON *.* TO 'mythtv'@'%' IDENTIFIED BY PASSWORD 'deleted' | 
| GRANT ALL PRIVILEGES ON `mythconverg`.* TO 'mythtv'@'%'                        
I deleted the password hash from this mail just in case..

Looks like anybody called mythtv should be able to connect from any machine.

So this test is the kicker:

More information about the mythtv-users mailing list