[mythtv-users] Trying to use upnp, weird issues

Mark J. Small msmall at eastlink.ca
Fri Jun 5 18:35:40 UTC 2009

On June 5, 2009, Brian Wood wrote:
> On Friday 05 June 2009 12:05:38 Mark J. Small wrote:
> > Hi everybody,
> >
> > I'm trying to use the upnp features of mythtv to serve my music and
> > pictures. I'm using the 0.21 packages from the stable tree of
> > debian-multimedia.org on a Debian Stable system.
> >
> > I've installed djmount on a separate machine, and it does not see any
> > upnp servers on my internal network.
> >
> > I've read the the ip address (not localhost), must be entered in to the
> > backend for upnp to work properly.  Well Mythtv-setup has the proper ip
> > address entered, but the setup->general screen in mythfrontend points to
> > localhost.  If I try to change this, then I can no longer connect to the
> > database, and the backend will not restart either.
> >
> > I've used nmap to check the standard upnp ports, but tcp 5000, 1900 and
> > udp 1900 are all closed.
> >
> > Does anyone have any advice?
> You need to have the real IP in both locations in your setup. I guess this
> means figuring out why things don't work when you set things up that way.
> I entered the real IP of a combined FE/BE machine in both locatons in the
> setup, once I did that the UPnP server function worked fine.
> Even if you could get the UPnP functions running with "localhost" you would
> still have a problem, because the URLs that your UPnP control point tried
> to go to would contain the localhost address, which would obviously not
> work.

Thanks for the quick reply.

To change the hostname in the frontend setup, should I do this?



-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://mythtv.org/pipermail/mythtv-users/attachments/20090605/1a2b4a08/attachment.htm>

More information about the mythtv-users mailing list