[mythtv-users] Is anybody able to change channels on a 4250HDC STB via firewire?

Christian Szpilfogel chrisznews4 at rogers.com
Fri Jun 5 00:36:10 UTC 2009

Matt Emmott wrote:
>         /* SA42xxHD IDs */
>         #define SA4200HD_VENDOR_ID1     0x000014f8
>         #define SA4200HD_MODEL_ID1      0x00001072
>         #define SA4250HD_VENDOR_ID1     0x00001106
>         #define SA4250HD_MODEL_ID1      0x00000000
>         Robert
> Everything _appears_ to be working but the box just isn't changing 
> channels. I'm able to plug a GUID from dmesg | grep 1394 into 
> sa4250_ch_ guid like so,
> matt at mythdev:~$ sa4250_ch_guid 00110666000000b8 56
> Changing channel 56
> But the channel never changes. If I run the non GUID version verbosely 
> I get:
> matt at mythdev:~$ sa4250_ch_new -v 56
> node 0: vendor_id = 0x00001106 model_id = 0x00000000
> Device acquired on node 0
> Changing channel 56
> AV/C Command: cmd0=0x00487ce7 cmd1=0x04003800 cmd2=0xff000000
> Again, with the channel never changing. I've tried powering everything 
> down, moving the cable to another firewire port and powering them back 
> on (STB first), with no result. Any ideas what to try next?
You are going to have to debug this lower down. I haven't seen these 
vendor IDs on an SA4250 (not necessarily an issue) and the Model ID of 0 
is unusual to me as well. Your thread however indicates you compiled 
those values into the channel changer.

In an earlier email you found:
/sa4250_ch -v
node 0: vendor_id = 0x00001106 model_id = 0x00000000
node 1: vendor_id = 0x000022ce model_id = 0x000010cc

22ce IS a Scientific Atlanta box and 10cc is a model as well. Have you 
tried this pair? Your thread suggests you did not.

I also asked you earlier for an output of plugreport and you did not do 
this. Can you do this?

sa4250_ch_new also has a "-n" parameter so if you have the constants 
correct then perhaps you want the following command:
sa4250_ch_new -n 1 -v 56

More information about the mythtv-users mailing list