[mythtv-users] Apple tv with mythbuntu will not boot

Kevin Johnson dabears_rule at yahoo.com
Mon Jun 1 19:21:13 UTC 2009

Okay guys, I need some help

Been at this all weekend and still no joy.

I have followed this guide exactly


Everything goes well and no errors seen.

I then follow this guide.


I do the netboot install and all goes well.

This is what I do.

Boot the AppleTV using atv-bootloader and connect using telnet. Then

mkdir tmp

mount /dev/sdb1 tmp

kexec --load tmp/linux --initrd=tmp/initrd.gz --command-line="vga=normal vesa video=vesafb"

kexec -e

I install ubuntu, no errors noticed.  I install system to partition 4 and swap to 5.

Now here is where I am stuck.

When I reboot the atv, nothing happens and the atv logo with the question mark appears.

So I stick in the atv-bootloader usb stick and it boots to give me the login prompt.

I can login.  I just don't know where to go from here??????

How do I start linux?  Should it start automatically?

If I run boot_linux.sh  this is what I get.


sda4/boot/brub menu.list found


kexec – load /mnt/rootfs/boot/vmlinux    (alot of numbers and stuff I am to tired to type)

kexec jump to new kernel

mount proc/mounts: No such file or directory

mount proc/mounts: No such file or directory

I have been at this all weekend and my eyes are shot.

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://mythtv.org/pipermail/mythtv-users/attachments/20090601/d95c9205/attachment.htm>

More information about the mythtv-users mailing list