[mythtv-users] 0.21 and no lock ...

Martin Koller kollix at aon.at
Sun Jul 12 14:12:12 UTC 2009

Following up to myself ...

On Sunday 24 May 2009, Martin Koller wrote:
> Hi,
> I'm using MythTV 0.21 on openSuse 11.0 since last year with 2 DVB-S cards, which
> work fine (I'm located in Austria; I have 1 dish with a quad-LNB, Astra 19.2E)
> Now I want to add a third DVB-S card into the same computer.
> I set up everything the same as the other cards, but with this new card
> I just get no lock. The signal shows e.g. 75%, S/N 4.6dB, Biterrors 13000-14000 (don't know
> what to do with that quick changing figures). The lock area just shows (l__) No Lock
> However, the same card works well with kaffeine and I can watch TV without
> problems.
> What is the difference between these two programs in terms of locking a channel ?
> I tried tuning with szap which also very quickly tells me FE_HAS_LOCK.
> I'm running all tests as root so I should not have any permission problems.
> All 3 cards are a different brand. The one which makes troubles with MythTV
> is a KNC1 TV-Station which also has a CI/CAM addon installed (I tried with and
> without a cryptocard inserted, and I'm first trying the FTA channels).

I found out that the card gets a lock in mythTV when the CI/CAM daughter card is not connected
(physically disconnected via unplugging the cable).

Trying to find out, where the problem is during the communication from mythTV and the CAM,
I recompiled libmythtv-0.21.so.0.21.0 and enabled the debugging in ./libmythtv/dvbdev/dvbci.cpp
via setting DebugProtocol = true;

I now get (still watching a non encrypted program):

2009-07-12 15:59:31.262 TVRec(9): Changing from None to WatchingLiveTV
2009-07-12 15:59:31.268 TVRec(9): HW Tuner: 9->9
Resetting slot 0...ok.
2009-07-12 15:59:31.944 DVB#0 CA: CI handler thread running
2009-07-12 15:59:31.944 DVB#0 CA: CI handler successfully initialized!
Module ready in slot 0
Creating connection: slot 0, tcid 1
2009-07-12 15:59:35.508 AutoExpire: CalcParams(): Max required Free Space: 5.0 GB w/freq: 15 min
OpenSession 00010041
New Resource Manager (session id 1)
1: ==> Profile Enq
OpenSession 00240041
New Date Time (session id 2)
1: <== Profile
1: ==> Profile Change
1: <== Profile Enquiry
1: ==> Profile
OpenSession 00020041
New Application Information (session id 3)
3: ==> Application Info Enq
3: <== Application Info
2009-07-12 15:59:40.000 CAM: CryptoWorks, 01, D000, 0000
OpenSession 00030041
New Conditional Access Support (session id 4)
4: ==> Ca Info Enq
4: <== Ca Info 0D05
2009-07-12 16:00:14.290 AutoExpire: CalcParams(): Max required Free Space: 5.0 GB w/freq: 15 min

Any Idea what causes the problem or any hint what other info I can provide ?

Best regards/Schöne Grüße

Martin    ()  ascii ribbon campaign - against html mail 
          /\                        - against microsoft attachments

Geschenkideen, Accessoires, Seifen, Kulinarisches: www.bibibest.at
-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 189 bytes
Desc: This is a digitally signed message part.
URL: <http://mythtv.org/pipermail/mythtv-users/attachments/20090712/6af3a772/attachment.pgp>

More information about the mythtv-users mailing list