[mythtv-users] OT: SATA errors

Harry Devine lifter89 at comcast.net
Thu Jul 9 13:07:30 UTC 2009

Matt Mossholder wrote:
> On Thu, Jul 9, 2009 at 8:45 AM, Glenn Harris 
> <gharris+list+mythtv at eklo.com 
> <mailto:gharris%2Blist%2Bmythtv at eklo.com>> wrote:
>     If you're going to be doing a lot of things as 'root', you can
>     just use:
>     sudo su -
>     That will prompt you for your normal sudo password, and give you a
>     full root shell.  Still no password for root, and all your commands
>     still get logged.
>     Everyone is happy.
>     Be careful still applies.
>     Good luck!
>     --Glenn
> Ack! No!  :)
> This is the correct method to get a root shell using sudo:
> sudo -i
>      --Matt
> ------------------------------------------------------------------------
> _______________________________________________
> mythtv-users mailing list
> mythtv-users at mythtv.org
> http://mythtv.org/cgi-bin/mailman/listinfo/mythtv-users
I was able to get fsck to work from the LiveCD using sudo and didn't 
have to go this route.  I'm going to try the power supply route first, 
and maybe put the OS hard drive into another machine and see if I can 
see it.

The weird thing with my SATA issue is that when it boots and I get all 
of those errors, I get dropped to a tty session and I'm prompted for my 
login.  Nothing is accepted.  I've tried my user name with the correct 
password, my user name with no password, root with the correct password, 
and root with no password.  All fail with "incorrect login".  So I can't 
even do any maintenance checks on the box right now.  It makes me think 
that the HD is spanked since the OS has no clue that any users even exist.


More information about the mythtv-users mailing list