[mythtv-users] gentoo, latest mythtv - mythfrontend has no text

John Drescher drescherjm at gmail.com
Mon Jul 6 17:22:52 UTC 2009

On Mon, Jul 6, 2009 at 1:05 PM, Tom Dexter<digitalaudiorock at gmail.com> wrote:
> On Mon, Jul 6, 2009 at 12:59 AM, Kingsley Turner<krt at krt.com.au> wrote:
>> Erik Hovland wrote:
>>> I booted my frontend this evening after being on vacation for a week.
>>> And up popped...no text. The interwebs are full of advice like setting
>>> DRI to off and XLIB_SKIP_ARGB_VISUALS=1. Those don't seems to work
>> I had this problem playing around with the video driver.
>> I had the theme background but no text.
>> The problem was twofold, but stemmed from me playing around with the video
>> driver - I had inadvertently broken OpenGL - but had configured MythTV to
>> use the OpenGL renderer for the user interface.
>> Repairing the video driver - GLX in particular, sorted it out immediately.
>> cheers,
>> -kt
> I just ran into a similar odd issue with my Gentoo frontend:
> I upgraded the kernel from 2.6.28-r5 to 2.6.29-r5.  When recompiling
> lirc it wanted to upgrade to lirc-0.8.5 so I did that.  When I
> rebooted and the frontend started, it displayed the background of my
> theme (I'm using glass-wide) and nothing else.
> I rebooted to the old kernel and everything worked fine.  Just out of
> curiosity I switched to another theme (MePo-wide) and booted to the
> new kernel.  That worked fine.  At that point I was able to switch
> back to the glass-wide theme and everything worked fine even if I
> rebooted.
> It seems as though, for whatever reason, it needed to rescale the
> theme images into cache in order to work correctly.  Now everything's
> fine.  Anyone ever see anything like that?

Rescaling of images happens every single time I upgrade mythtv.


More information about the mythtv-users mailing list