[mythtv-users] Mythdora 5 + ATI Remote Wonder II = Help

Peter Caylor pgcaylor at gmail.com
Sat Jan 24 21:30:04 UTC 2009

I am having some trouble getting my ATI Remote Wonder II remote working with
LIRC.  I am using Mythdora 5 and the install process ran properly except
that LIRC does not work.

LIRC does not appear to load at all during startup.  lsmod | grep lirc comes
back with nothing.  If I modprobe lirc_atiusb, lirc_atiusb & lirc_dev both
load, and they do not give any errors in dmesg, but when I start lircd
afterwards no /dev/lirc or /dev/lirc0 devices are created.  No errors are
being generated that I can find.  If I start lircd from the terminal, it
starts without error, but still does not create /dev/lirc or /dev/lirc0.
(Running irw fails after this, but I assume that's because it can't find a
valid lirc device to use.)

I have blacklisted the ati_remote kernel modules to avoid conflict with the
lirc_atiusb driver.  My lircd.conf file was created by the Mythdora script,
and it appears to be correct for a Remote Wonder II so I don't think it's a
lircd.conf problem, but if anybody has a known-good lircd.conf file for a
Remote Wonder II I'd appreciate a copy.  (My lircd.conf also matches the one
in the Remote Wonder II section of the wiki, so I'm assuming it's good.)

dmesg output from a manual modprobe:
lirc_dev: IR Remote Control driver registered, major 61
lirc_atiusb: USB remote driver for LIRC $Revision: 1.68 $
lirc_atiusb: Paul Miller <pmiller9 at users.sourceforge.net>
usbcore: registered new interface driver lirc_atiusb

Any suggestions on where to look would be appreciated.  At this point, I'd
even be happy to get an error message.  At least then I'd have something to
start troubleshooting from.


-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://mythtv.org/pipermail/mythtv-users/attachments/20090124/4d9a6c9e/attachment.htm>

More information about the mythtv-users mailing list