[mythtv-users] Mythfrontend ignores key/remote input, playback intermittently unresponsive

Quinten Steenhuis q.steenhuis at yahoo.com
Fri Jan 23 16:17:36 UTC 2009

This has been in the archives for a while, but I was hoping that somebody might have some new insight into this problem, which is starting to seriously harm my relationship with my fiancee :). I believe it is related to this long-standing bug: http://svn.mythtv.org/trac/ticket/5660

For me, mythtv is seriously broken, especially when the bug occurs if I'm fast forwarding. I am happy to try a radical solution if it will fix my problem (like upgrading to trunk). I'm willing to buy new hardware, within reason. My other option is going back to standard def TiVO, which I really don't want to do. Really, I'd like to help fix this problem and help more people use an opensource solution with a lot of potential.

At least once per session now, when I am watching either live TV or recorded TV, MythFrontend will simply ignore my key and remote presses. Then, it plays them back all at once, as if queued up. While it is ignoring the keys, fast forward or regular play seem to be fine. I just can't pause or change the speed of playback for a while, usually about 30 seconds to a minute.

Following the notes of a few other people with the same issue, I tried alt+tab, and the rest of the machine is still responsive-alt-tab immediately switches, I can type in an xterm, etc. The machine is also very responsive to commands via an open SSH session. Load is relatively high, but on a dual-core machine, less than 80% load. This happens when watching HD and SD content alike, although maybe a bit more frequently with HD. Sometimes mythcommflag is running, and sometimes it isn't. The machine is used as a backend and frontend, but nothing else is running on it.

I am not running gnome-screensaver. In fact, I completely removed it from the system, and I am not running any other screensaver. I am running the newest weekly build, but I had the same problem in the stock mythbuntu 8.10 version of Mythtv. One possible wrinkle is that I installed gnome-desktop, and I haven't completely removed it--just removed pieces of it, such as the screensaver component. Other differences from a stock install: I added irexec to my .xinitrc to allow me to set my remote control to restart mythfrontend. However, the problem existed before I added this.

I have tried with/without "enable realtime threads." Looking at the help for that setting, it appears that mythfrontend has to run setuid root for it to work. Is that correct, and in mythbuntu, is that the default or not? Does this have a significant performance advantage? What's the proper/best way to set it to run as root?

System specs: 
Mythtv version 19693, mythbuntu packages, UK weekly build
2 GB DDR ram
3.2 ghz Athlon 64 X2 (dual core)
HD Homerun
Western Digital Greenpower 1TB hard drive
connected via HDMI to tv
NVidia 8200 onboard, 177.82 drivers
Vista MCE remote, MCEUSB2 drivers (el-cheapo from Newegg, E-Data tech DEC-200B)

Does this problem still exist in trunk? Should I try different video drivers? A different remote control/ir input device? An experimental version of lirc? If anybody has any suggestions, let me know. Even just an idea about where to look in the various mythtv components for what's stalling so that I can figure out my own solution...


More information about the mythtv-users mailing list