[mythtv-users] Issues with audio over HDMI

Erik de Jong erik at and.li
Thu Jan 22 20:29:54 UTC 2009

Hi Phil, and others experiencing problems ;-)

(apologies for not responding inline, working with outlook for the moment)

I have different hardware (onboard AMD) yet suffered from similar issues. I
documented the shortest route that worked for me and that I suspect may give
you clues in the right direction on different hardware as well. Here's what
I did:

$ sudo alsactl names

This will output a list of audio/alsa devices into /etc/asound.names

Going through /etc/asound.names, the two relevant entries for me were:

alsactl19 {
        name 'hw:1,3'
        comment 'Physical Device - ATI HDMI (Playback)'
alsactl20 {
        name 'plughw:1,3'
        comment 'Physical Device With Conversions - ATI HDMI (Playback)'

I found that the first one worked sometimes and the second one always, I
suspect this to depend on the format of the audio.

In mythfrontend -> Utilities/Setup -> Setup -> General -> page 3 I used


for both "audio output device" and "passthrough audio device".

Unchecked "use internal volume controls"

Lastly, make sure sound over HDMI is not muted:

$ sudo alsamixer -c 1
(-c 1 to select the second device, see device name from asound.names)

Choose the right channel and press 'm' to unmute if needed.

Hope this helps. For me being able to actually go through the list of my
devices in /etc/asound.names was the break-through.


-----Oorspronkelijk bericht-----
Van: Phil Wild [mailto:philwild at gmail.com]
Verzonden: zondag 18 januari 2009 14:49
Aan: Discussion about mythtv
Onderwerp: [mythtv-users] Issues with audio over HDMI

Hello all,

I am chasing some expert advice...

I am building my first MythTV frontend. I have an Asus m3n78-em motherboard
with onboard HDMI. I have install mythbuntu amd64. I have upgraded alsa to

I can send audio to the TV through hdmi using aplay

e.g. aplay /usr/share/sounds/card_shuffle.wav

aplay -l lists

root at juliette:~# aplay -l
**** List of PLAYBACK Hardware Devices ****
card 0: NVidia [HDA NVidia], device 0: ALC1200 Analog [ALC1200 Analog]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: NVidia [HDA NVidia], device 1: ALC1200 Digital [ALC1200 Digital]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: NVidia [HDA NVidia], device 3: NVIDIA HDMI [NVIDIA HDMI]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
root at juliette:~#

and I have setup a default entry in /etc/asound.conf as

pcm.!default {
        type hw
        card 0
        device 3

More information about the mythtv-users mailing list