[mythtv-users] mythtranscode: am I doing something wrong, or is this a bug?

Misty P mistyp at thekorn.net
Wed Jan 21 10:43:00 UTC 2009

John Pilkington wrote:
> Misty P wrote:
>> vince at Mythtical:/var/log/mythtv$ ls -l
>> /mythtv/videos/1051_20080808184500.nuv
>> -rw-r--r-- 1 mythtv mythtv 28623644884 2008-09-01 07:56
>> /mythtv/videos/1051_20080808184500.nuv
>> And then I cranked over mythtranscode:
>> mythtranscode --chanid 1051 --starttime 2008-08-08-18-30-00 --mpeg2
>> --honorcutlist --showprogress -v important
> Try --starttime 20080808184500

Hey!  That worked!  (...well, I was able to get farther, anyway.)

> and I'm not sure that --mpeg2 will work with this file

It didn't.  (Said no more queue slots, but whatever.)  I changed the command 
line to:

mythtranscode --chanid 1051 --starttime 20080808184500 --profile 
autodetect --honorcutlist --showprogress -v important

And now it pukes identically to jobs fired off from the UI:

2009-01-21 04:34:14.923 Using runtime prefix = /usr
2009-01-21 04:34:14.923 Empty LocalHostName.
2009-01-21 04:34:14.928 New DB connection, total: 1
2009-01-21 04:34:14.931 Closing DB connection named 'DBManager0'
2009-01-21 04:34:14.931 Enabled verbose msgs: important
2009-01-21 04:34:14.933 New DB connection, total: 2
2009-01-21 04:34:14.941 Using protocol version 40
2009-01-21 04:34:14.951 Found video height of 1088.  This is unusual and 
more than likely the video is actually 1080 so mythtranscode will treat it 
as such.
2009-01-21 04:34:14.951 Transcode: Looking for autodetect profile: 
Autodetect from 1080i
2009-01-21 04:34:14.952 New DB connection, total: 3
2009-01-21 04:34:14.958 Transcode: Using autodetect profile: RTjpeg/MPEG4
2009-01-21 04:34:14.958 No video information found!
2009-01-21 04:34:14.958 Please ensure that recording profiles for the 
transcoder are set

Since it seemed to be complaining about a profile, just for giggles I hit 
mythtranscode with "--profile 1" (whatever THAT profile is) but that didn't 
change the symptoms.  (Still complains about no video information found.)

Thanks so far...  Any more ideas?  I tried -v all, but all that gave me was 
more information about the database calls instead of the video problem. 
(...so I'm not bothering to echo that output here.)

More information about the mythtv-users mailing list