[mythtv-users] webservices.schedulesdirect.tmsdatadirect.com -- 401 unauthorized

Brad DerManouelian myth at dermanouelian.com
Thu Jan 15 21:09:27 UTC 2009

On Jan 15, 2009, at 1:01 PM, Igor Chudov wrote:

> I registered for a 7 day of Schedules Direct trial yesterday, hoping
> to test this service out before paying to use it.
> I use MythTV on Ubuntu Intrepid.
> When running mythfilldatabase, I get a lot of errors such as this one:
> 2009-01-15 14:49:44.715 Grabbing listing data
> --2009-01-15 14:49:44-- http://webservices.schedulesdirect.tmsd
> ... tvdService
> Resolving
> webservices.schedulesdirect.tmsdatadirect.com...
> Connecting to
> webservices.schedulesdirect.tmsdatadirect.com||:80...
> connected.
> HTTP request sent, awaiting response... 401 Unauthorized
> Reusing existing connection to
> webservices.schedulesdirect.tmsdatadirect.com:80.
> HTTP request sent, awaiting response... 401 Unauthorized
> Authorization failed.
> 2009-01-15 14:49:44.972 Grab complete. Actual data from to (UTC)

This is supposed to happen. You're getting redirected to a "please  
sign in" type of page after your initial attempt fails. Then a second  
attempt is made and it works.

> They scroll by very quickly.
> As a result, my database is not populated with TV schedule.
> Sadly, MythTV is not telling me anything useful such as what
> credentials it uses and what exactly it tries to pull, but I
> definitely specified right credentials upon running mythtv-setup.

It specifically asks for your login and password to schedules direct.

> A few hundred lines later, mythfilldatabase succeeded pulling some
> other files and said DataDirect: Your subscription expires on 01/21/09
> 08:03:11, which suggests that the credentials that I supplied are
> correct.

...which you have provided correctly.

> The end result is that I have no schedule, so mythtv does not
> work. The symptom is that when I select "Watch TV" I return right back
> to the original menu with zero explanation. Mythtv-status says:
> ==>mythtv-status
> No config found; attempting to find mythbackend via UPnP.

This looks like the user you're running as does not have a valid  
config file.

> MythTV status for localhost
> ===========================
> Status...........: Thu Jan 15 2009, 3:00 PM
> Total Disk Space.: Total space is 36,382 MB, with 9,360 MB used  
> (25.7%)
> Next Recording In: Never
> Guide Data.......: No guide data!

This looks like you haven't assigned the correct input with your  
listing source in mythtv-setup. Basically, you've told mythtv to  
create a lineup, but haven't told it which video capture card input to  
use with that lineup. At least, that's my guess without knowing how  
you've set everything up.

> Schedule Conflicts:
> Unable to access MythTV Perl API.  Try with --verbose to find out why.

This looks like you haven't installed the mythtv perl bindings.


More information about the mythtv-users mailing list