[mythtv-users] KWorld ATSC-115 problems -- can't change channel, no sound

David Lonie loniedavid at gmail.com
Fri Jan 2 02:15:13 UTC 2009

On Thu, Jan 1, 2009 at 4:26 PM, David Lonie <loniedavid at gmail.com> wrote:
> On Thu, Jan 1, 2009 at 4:08 PM,  <alan.mcendoo at att.net> wrote:
>> It sounds like you have the same problem I had with the KWorld 115 TV card.
>> In my case it emerged when I upgraded from Ubuntu 8.04 to Ubuntu 8.10.  I
>> had set the card up using the information at
>> http://www.mythtv.org/wiki/index.php/Kworld_ATSC_110 in Ubuntu 8.04 where it
>> worked in both analog and digital modes.  When I upgraded to Ubuntu 8.10 I
>> had the same symptoms described, either just noise, or one channel without
>> the ability to change it.  Others upgrading to Ubuntu 8.10 had the same
>> issue.  It seems that the issue was with the V4l drivers packaged with
>> different versions of the basic kernel.  At some point (back in the first
>> quarter of 2008) a change was made to the drivers that resulted in a timing
>> issue loading tuner modules on the i2c bus which basically means there is no
>> tuner control on the KWorld 110/115 cards.  This was discussed on the V4l
>> lists, https://www.redhat.com/mailman/private/video4linux-list in June and
>> December 2008 and on the list
>> http://www.avsforum.com/avs-vb/showthread.php?s=3569fb8ac624936b75259474b3a0cefc&t=1050693.
>> There is a patch which can be used to get it working, but it may raise
>> issues with other V4l devices in use.  The fix is described on the Ubuntu
>> forum http://ubuntuforums.org/showthread.php?t=959407&highlight=Kworld+115.
>> The method is not unique to Ubuntu but should work for any linux type.
>> Hope this helps.
> Looks like it should! Glad to see that it's a known issue -- I was
> going nuts seeing all the reports of how wonderful this card is when I
> couldn't get mine set up :) Strange that none of this showed up during
> my days of googling. I see ubuntu 8.10 uses 2.6.27 -- that's what I'm
> running so chances are they're the same drivers. I'll try out that
> patch later today and post the results here.

Ok -- that sort of works. Here's where I'm at now:

* Using the patched drivers and reloading the tuner module (I still
can't figure out why, but it is necessary...), the input switches, and
the channel can change again.
* Still no sound from the Kworld card, although aplay /dev/dsp2 (the
kworld's dsp) allows me to hear the sound from the card, but obviously
is no good for myth.
* While watching the kworld card in myth, fuser shows /dev/dsp2 in use
by myth, though no sound comes out....
* While the saa7134 drivers are loaded there is no sound from my PVR-150 (!!)
* Unloading the saa7134's and restarting the backend allows the
PVR-150 to work ok again.

Since dsp2 works on it's own and the PVR-150's sound works while the
saa's are not loaded, it seems that myth maybe isn't handling the two
streams properly? myth is tying up the correct dsp....

This is in my log:

2009-01-01 19:47:12.698 Opening audio device 'cards.pcm.iec958'. ch
2(2) sr 32000
2009-01-01 19:47:12.698 Opening ALSA audio device 'cards.pcm.iec958'.
2009-01-01 19:47:12.699 AudioOutput Error: Rate doesn't match
(requested 32000Hz, got 44100Hz)
2009-01-01 19:47:12.700 AudioOutput Error: Unable to set ALSA parameters
2009-01-01 19:47:12.700 NVP: Disabling Audio, reason is: Unable to set
ALSA parameters
2009-01-01 19:47:12.721 VideoOutputXv: XVideo Adaptor Name: 'NV17 Video Overlay'

I'm wondering if the data on the wiki is outdated for the 115? Did
anyone else have to set the sampling rate to 32000 like it said and
have it work?

I took that option out and the PVR-150 and the KWorld both work now
... sort of. The PVR-150 is back to normal, but the picture on the
Kworld is VERY studdery and the audio is high pitched and intermittent
-- like it's reading it to fast and running out the buffer. But the
audio is there, so that is a step in the right direction...

The output from aplay is:

gentoo-server mythtv # aplay /dev/dsp2
Playing raw data '/dev/dsp2' : Unsigned 8 bit, Rate 8000 Hz, Mono

and the audio sounds fine. There is no 8000 Hz limit on the audio in
mythtv, and I'm not even sure these would be the same rates :D Anyone
have similar problems to these?

More information about the mythtv-users mailing list