[mythtv-users] Experience Installing Hauppauge WinTV-HVR-1600 card and Remote/Blaster

Larry on the Dell Laptop larry at foxgulch.com
Sat Feb 28 15:36:26 UTC 2009

> Thanks.  Unfortunately,  I wasn't able to get the WinTV HVR-1600 kit 
> blaster  and mce usb remote working using the MCC configuration 
> utility  where in I selected REMOTE="Windows Media Center Remotes (new 
> version Philips et al" and TRANSMITTER="Microsoft Windows Media Center 
> V2 (usb) : Dish Receiver"  When and if I get it working, I'll post 
> here.  At this time,  no output from IRW after a sudo /etc/init.d/lirc 
> restart.
> Larry
> _______________________________________________
> mythtv-users mailing list
> mythtv-users at mythtv.org
> http://mythtv.org/cgi-bin/mailman/listinfo/mythtv-users
Here's one more piece of the puzzle solved.  IRW now gives me output 
after making the single change detailed below.  This using the WinTV  
HVR-1600 model 1183 with supplied MCE usb remote.  Here's some info 
about the remote:

The black remote has a label on its back which reads RRS9002-86XXF  
Inside of Battery Compartment is a label reading 81117B

I've identified the remote that was supplied with the HVR-1600 Kit from 
NewEgg as  a MCE (Windoze Media Center)  "Version 2" and looks identical 
to the Version 2,  1069 Model shown here:

When I plugged the infra-red usb attachment, I found it identified like 

lj at mythtv:~$ lsusb
Bus 002 Device 006: ID 1784:0001 TopSeed Technology Corp.

The manufacturer's web site is here:

The manufacturer suggests this remote RC6 IR protocal and needs Windows 
Media Center.

But at this point,  still no output from irw.  Then I noticed that in 
/dev my mythbuntu 8.10 install  was only showing /dev/lirc0

lj at mythtv:/etc/lirc$ ls -al /dev/lirc*
crw-rw---- 1 root root 61, 0 2009-02-28 08:30 /dev/lirc0
srw-rw-rw- 1 root root     0 2009-02-28 09:06 /dev/lircd

Yet in /etc/lirc/hardware.conf,  the line for the TRANSMITTER_DEVICE read:

So I just arbitrarily changed that line  ( using sudo gedit 
/etc/lirc/hardware.conf) to:

I then restarted lirc:
lj at mythtv:/etc/lirc$ sudo /etc/init.d/lirc restart
 * Stopping remote control daemon(s): LIRC                  [ OK ]
 * Loading LIRC modules                                             [ OK ]
 * Starting remote control daemon(s) : LIRC   

Then in a terminal I started irw and noted valid remote key presses:
lj at mythtv:~$ irw
000000037ff07be1 00 Up mceusb
000000037ff07be1 01 Up mceusb
000000037ff07be1 02 Up mceusb
000000037ff07bdd 00 OK mceusb
000000037ff07bdd 01 OK mceusb
000000037ff07bdd 02 OK mceusb

So the top part of my /etc/lirc/hardware.conf  now reads:
# /etc/lirc/hardware.conf
#Chosen Remote Control
REMOTE="Windows Media Center Remotes (new version Philips et al.)"
REMOTE_MODULES="lirc_dev lirc_mceusb2"

#Chosen IR Transmitter
TRANSMITTER="Microsoft Windows Media Center V2 (usb) : Dish Receiver"
TRANSMITTER_MODULES="lirc_dev lirc_mceusb2"

Now to see if I can get my cranky DishNetwork Satellite Receiver to 
change channels using the supplied blaster.


More information about the mythtv-users mailing list