[mythtv-users] Hauppauge remote and mythfrontend 0.21: strange delay

Steve Wesemeyer swesemeyer at ntlworld.com
Tue Feb 24 11:18:27 UTC 2009


I have recently upgraded my mythtv install from 0.20-fixes to 0.21.1-fixes 
(while also upgrading Opensuse 10.3 to 11.1). Everything upgraded with almost 
no hitch. However, there is one thing that I can't seem to figure out.
I'm using a Nova-T 500 DVB-T and a Nova-S DVB-S card and my remote(the 
standard Hauppauge remote that comes with these cards) is connected to the 
Nova-T 500. 

The remote works fine and I can control the frontend from it. However, I have 
to wait for about 2 minutes after the frontend starts up before it responds 
to keypresses from the remote. In other words, mythfrontend is up and 
running. It just does not respond to keypresses from my remote for 2 minutes 
while it does respond to keypresses from my wireless keyboard during that 
period. This used to work fine in the previous install.

I ran the frontend with -v all and saw no obvious error messages. However, 
what I noticed was that the MediaMonitor in the frontend tried to mount 
various /dev/sdc, sdd, sde and sdf devices which correspond to the installed 
Once it failed to mount these devices (which takes about 2 minutes) it starts 
monitoring the DVD-drive  and subsequent checks of the sdc, sde, sdf devices 
are much faster.This is the point at which the frontend starts responding to 
keypresses from my remote.

Has anyone experienced something similar or has some ideas how to get the 
remote working straightaway like it used to in the previous install?


mythfrontend --version:

MythTV Version   : 19871M
MythTV Branch    : branches/release-0-21-fixes
Library API      : 0.21.20080304-1
Network Protocol : 40
Options compiled in:
 linux release using_oss using_alsa using_arts using_jack using_backend 
using_dbox2 using_directfb using_dvb using_firewire using_frontend 
using_hdhomerun using_iptv using_ivtv using_joystick_menu using_lirc 
using_v4l using_x11 using_xrandr using_xv using_xvmc using_xvmcw 
using_xvmc_vld using_bindings_perl using_bindings_python using_opengl 
using_ffmpeg_threads using_libavc_5_3 using_liv

This is the output of the mythfrondend -v all:

2009-02-23 16:11:01.034 Media status changed, but not sending event 
2009-02-23 16:11:01.035 MythMediaDevice::isMounted() - mount of '/dev/sdd' not 
                 Device name/type | Current mountpoint
                        /dev/sda2 | /
                        /dev/sda1 | /boot
                        /dev/sda3 | /home
                        /dev/sda6 | /linux1
                        /dev/sda7 | /mythtv
                       /dev/sdb1 | /data
2009-02-23 16:11:01.036 MythMediaDevice::isMounted() - mount of '/dev/sdd' not 
                 Device name/type | Current mountpoint
                        /dev/sda2 | /
                        /dev/sda1 | /boot
                        /dev/sda3 | /home
                        /dev/sda6 | /linux1
                        /dev/sda7 | /mythtv
                        /dev/sdb1 | /data
2009-02-23 16:11:01.036 Executing '/bin/mount /dev/sdd'
2009-02-23 16:11:07.041 MythSocket(82e1030:14): socket is readable
2009-02-23 16:11:07.041 MythSocket(82e1030:14): cb->readyRead()
2009-02-23 16:11:17.041 MythSocket(82e1030:14): socket is readable
2009-02-23 16:11:17.041 MythSocket(82e1030:14): cb->readyRead()
2009-02-23 16:11:27.041 MythSocket(82e1030:14): socket is readable
2009-02-23 16:11:27.041 MythSocket(82e1030:14): cb->readyRead()
mount: can't find /dev/sdd in /etc/fstab or /etc/mtab
2009-02-23 16:11:31.069 Failed to mount /dev/sdd.
2009-02-23 16:11:31.070 MythMediaDevice::isMounted() - mount of '/dev/sdd' not 

More information about the mythtv-users mailing list