[mythtv-users] rsync deleted source and destination while moving recordings to a new drive

Boleslaw Ciesielski bolek-mythtv at curl.com
Fri Feb 20 13:55:46 UTC 2009

jarpublic at gmail.com wrote:
> I am afraid I really screwed up this time but I thought somebody here 
> may be able to help me. I was in the process of retiring an old drive 
> and moving all of my recordings to a new drive. I used rsync -avrpPH 
> /mnt/data-a/mythtv/recordings /mnt/data-b/mythtv/recordings/ to do the 
> initial transfer and everything worked fine. Then just before I was 
> going to get ready to repurpose the old drive I ran the same command one 
> more time to pick up any additional recordings and I added the --del 
> option. This was my fatal mistake (yes the small voice in my head said, 
> "use the dry-run option just in case"). My understanding (or I should 
> say my misunderstanding from my quick read of the man page) was that 
> this would delete files from the source after they had been synced to 
> the destination. Either I made a syntax mistake or as I suspect from 
> rereading the man page, the --del will remove a file from both the 
> source and the destination. So now my recordings folder are empty on 
> both the source and destination.

Check if you have /mnt/data-b/mythtv/recordings/recordings folder. I 
think the meaning of your command line is different depending on whether 
the target directory exists or not.


More information about the mythtv-users mailing list