[mythtv-users] rsync deleted source and destination while moving recordings to a new drive

jarpublic at gmail.com jarpublic at gmail.com
Fri Feb 20 09:40:14 UTC 2009

I am afraid I really screwed up this time but I thought somebody here may be
able to help me. I was in the process of retiring an old drive and moving
all of my recordings to a new drive. I used rsync -avrpPH
/mnt/data-a/mythtv/recordings /mnt/data-b/mythtv/recordings/ to do the
initial transfer and everything worked fine. Then just before I was going to
get ready to repurpose the old drive I ran the same command one more time to
pick up any additional recordings and I added the --del option. This was my
fatal mistake (yes the small voice in my head said, "use the dry-run option
just in case"). My understanding (or I should say my misunderstanding from
my quick read of the man page) was that this would delete files from the
source after they had been synced to the destination. Either I made a syntax
mistake or as I suspect from rereading the man page, the --del will remove a
file from both the source and the destination. So now my recordings folder
are empty on both the source and destination. Both are located on XFS
partitions. I shutdown the system so the drives won't get changed at all. Is
there any hope of me getting these back? How do I do it? Google wasn't my
friend on this one. If not it is ok it was about 150 gigs and it was mostly
kids shows and some movies from tv.

My next question is if I can't get the recordings back how do I clean up the
database so that those shows/movies can be recorded again? Will running the
find orphans script in the contrib folder do the job? Or will they all still
be marked as previously recorded in the database? Any help will be greatly
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://mythtv.org/pipermail/mythtv-users/attachments/20090220/47b3b4ab/attachment.htm>

More information about the mythtv-users mailing list