[mythtv-users] HDMI ac3 passthough audio

JP Fournier jape41 at gmail.com
Sat Feb 14 22:58:41 UTC 2009

Thanks.  This did help.  I not sure why I had difficulty.  Perhaps I had max
channels set incorrectly?  In any event these are the settings that work for

Audio output device: ALSA:iec958
Passthrough output device: ALSA:iec958:{ AES0 0x02 }
Max Audio Channels: Stereo
Upmix: passive
Enable AC3 to SPDIF passthrough: on
Enable DTS to SPDIF passthrough: on
Aggressive soundcard buffering: off
Use internal volume controls: off

And this is the radeonhd thread that allowed me to get it working:




On Mon, Feb 9, 2009 at 8:24 PM, Allen Edwards <allen.p.edwards at gmail.com> wrote:
> On Mon, Feb 9, 2009 at 5:16 PM, JP Fournier <jape41 at gmail.com> wrote:
>> Hi All,
>> After I got some help from the radeonhd driver list, I am now able to play
>> ac3
>> audio over HDMI with mplayer via a command line like this:
>> mplayer -ac hwac3 -ao alsa:device=iec958=1 -vo xv -fs
>> 2041_20090208074700.mpg
>> Can anyone help me figure out what the equivalent settings under mythtv
>> would
>> be? Obviously I've tried a few variations, but the best I can get is
>> clicky
>> static.
>> regards,
>> jp
> Time to send this out again.  Let me know if you have any additions to this
> advice:
> Allen
> --------------------------------------------------------------------------------------------------------------------------
>                      SPDIF over MYTHTV
> --------------------------------------------------------------------------------------------------------------------------
> For spdif I recommend the following settings:
> -----------------------hdmi-----------------------------------
> For HDMI cards
> Update nvidia drivers.  Mythbuntu users can use "envyng -t" from the command
> line after installing it.
> Update alsa
> run aplay -l and look for an output like this:
>   Subdevices: 1/1
>   Subdevice #0: subdevice #0
> card 0: NVidia [HDA NVidia], device 3: NVIDIA HDMI [NVIDIA HDMI]
> For this case, the key is card o device 3.
> Then use this setup:
> Audio output device: ALSA:hw:0,3
> Passthrough output device: ALSA:hw:0,3
> Max Audio Channels: Stereo
> Upmix: Passive
> Enabale AC3 to SPDIF passthrough checked
> Enable DTS to SPDIF passthrough checked
> Aggressive sound card buffering off
> Use internal volume controls off
> For mythmusic: (note, this looks like it is using pulse audio.  There may be
> another way)
> Utilities/Setup -> Setup -> Media Settings -> Music Settings -> General
> Settings
> and then set Audio device to ALSA:plughw:0,3
> Optional for myth but perhaps a good or bad thing:
> asound.conf:
> pcm.!default {
>         type hw
>         card 0
>         device 3
> }
> If you have problems test without myth
> mplayer -ao alsa:device=hw=0.3 -afm hwac3 /some/dolbydigital/audio/file.wav
> This will verify the hardware
> ------------------m3n78-em------------------------------------
> 1st post:
> For the m3n78-em with the optical spdif connector on the MB the kernel
> module must be loaded with this option:
> options snd-hda-intel model=6stack-dig
> 2nd post:
> in MythBuntu i added the same line to /etc/modprobe.d/alsa-base, or, i
> should say, the script i ran to update my alsa drivers added it for
> me.
> ----------------------general------------------------------------
> Audio output device: ALSA:spdif  <--- this doesn't work for HDMI cards.  See
> above
> Passthrough output device: ALSA:iec958(AESO 0x02)
> max Audio Channels: Stereo  (this feature is broken so this is the required
> setting even if you want surround sound)
> Upmix: Passive
> Enable AC3 to SPDIF passthrough (checked)
> Enable ETS to SPDIF passthrough (checked)
> Aggressive Sound Card Buffers (unchecked)
> Use internal volume controls (unchecked)
> Remove or rename asound.conf and .asoundrc if it exists.
> If you are running Fedora, remove pulseaudio and all its files.
> There was a post that outlined the process but it is gone.  A copy is below.
> Run alsamixer and enable iec958.  Use the right arrow key to see it.
> -----------------------------Fedora and pulse audio
> removal------------------------------------
> Copy of someone else's post:
> The steps I followed were:
> -1- Rename (add "-orig") to cripple:    /etc/pulse
>                                        /etc/pulse/default.pa
>                                        /root/pulse-cookie
>                                        /home/<user name>/.pulse-cookie
> -2- Run   rpm -qa | grep "pulse"   and   rpm -qa | grep "pa"    to find
> the stuff loaded for pulse audio.  Remove it via yum ("yum remove xxx"),
> one item below per run:
>                        pulseaudio
>                        alsa-plugins-pulseaudio
>                        pavucontrol
>                        pulseaudio-utils
>                        gstreamer-plugins-pulse
>                        pulseaudio-core-libs
>                        akode-pulseaudio
> This leaves:    libflashsupport
>                pulseaudio-libs
>                akode-pulseaudio
> To remove these would take too many other dependencies.
> IIRC, there were subsequent notes on several sites that removing only
> alsa-plugins-pulseaudio was enough.  I'm not certain that "I recall
> correctly" and even if I do, it might not be enough for Fedora 9.  But
> I'd probably try that first to see if it (alone) works.  Besides, since
> you'll eventually need to do it, there's no harm.
> ---------------------------------------------------------------------------
> Another useful post:
> Hi Phil, and others experiencing problems ;-)
> (apologies for not responding inline, working with outlook for the moment)
> I have different hardware (onboard AMD) yet suffered from similar issues. I
> documented the shortest route that worked for me and that I suspect may give
> you clues in the right direction on different hardware as well. Here's what
> I did:
> $ sudo alsactl names
> This will output a list of audio/alsa devices into /etc/asound.names
> Going through /etc/asound.names, the two relevant entries for me were:
> alsactl19 {
>        name 'hw:1,3'
>        comment 'Physical Device - ATI HDMI (Playback)'
> }
> alsactl20 {
>        name 'plughw:1,3'
>        comment 'Physical Device With Conversions - ATI HDMI (Playback)'
> }
> I found that the first one worked sometimes and the second one always, I
> suspect this to depend on the format of the audio.
> In mythfrontend -> Utilities/Setup -> Setup -> General -> page 3 I used
> ALSA:plughw:1,3
> for both "audio output device" and "passthrough audio device".
> Unchecked "use internal volume controls"
> Lastly, make sure sound over HDMI is not muted:
> $ sudo alsamixer -c 1
> (-c 1 to select the second device, see device name from asound.names)
> Choose the right channel and press 'm' to unmute if needed.
> Hope this helps. For me being able to actually go through the list of my
> devices in /etc/asound.names was the break-through.
> Erik.
> _______________________________________________
> mythtv-users mailing list
> mythtv-users at mythtv.org
> http://mythtv.org/cgi-bin/mailman/listinfo/mythtv-users

More information about the mythtv-users mailing list