[mythtv-users] I killed XvMC with a little test. Help!

Allen Edwards allen.p.edwards at gmail.com
Thu Feb 12 17:10:20 UTC 2009

On Thu, Feb 12, 2009 at 7:15 AM, Adam Stylinski <kungfujesus06 at gmail.com> wrote:
> Allen Edwards wrote:
>> My aux FE was just fine when and ran envyng to updage the nvidia
>> driver.  Now any recorded show that requires XvMC to play (HD shows)
>>  takes mythfrontend to 100% and a black screen with mythfrontend
>> locked up.
>> mythfrontend.log shows this as the last thing:
>> 2009-02-11 20:20:22.115 TV: Changing from None to WatchingPreRecorded
>> 2009-02-11 20:20:22.120 Failed to approve 'none' deinterlacer
>> 2009-02-11 20:20:22.121 Couldn't load deinterlace filter
>> 2009-02-11 20:20:22.121 Realtime priority would require SUID as root.
>> 2009-02-11 20:20:22.143 XvMC: picture structure FRAME
>> If I change from CPU--, which uses XvMC to SLIM, the show will play
>> but not smoothly so it is unwatchable.  Thus it isn't the recording.
>>  I have tried several recordings.  SD recordings play fine.  You will
>> notice from the log that I turned deinterlacing to "none" to simplify
>> the problem.  It didn't help.  I tried putting in a new video card, a
>> 5200 and updated the driver again and it acts the same.  I removed the
>> driver and used the nvidia-xconfig to install it and it acts the same.
>>  Nothing helps.
>> P4 2.4GHz
>> Nvidia 5200 AGP
>> RGB monitor
>> Mythbuntu 8.04
>> branches/release-0-21-fixes version 19878
>> I don't know what happened.  I was just trying to verify some things
>> for the wiki I am writing and now my system is broken.
>> I posted some of this within another thread but thought it better to
>> start a new one.
>> Allen
>> ------------------------------------------------------------------------
>> _______________________________________________
>> mythtv-users mailing list
>> mythtv-users at mythtv.org
>> http://mythtv.org/cgi-bin/mailman/listinfo/mythtv-users
> Unfortunately Nvidia broke XvMC with AGP a WHILE ago.  The only way to
> make it work is literally to disable AGP with the NvAGP option in
> Xorg.conf.  For more info in my attempts to get Nvidia to pay any
> attention to the problem, here is my post on the nvnews.net forums:
> http://www.nvnews.net/vbulletin/showthread.php?t=118738
> It's not card specific, it's something that occurs on pretty much any
> card with any GART implementation.  PCI Express users have it just fine.

I noticed this problem with 96.43.12.  Is there a driver that I should
use to avoid this problem?  On the other hand, it seems to work fine
with NcAGP 0.

What is the common wisdom here?

I added a note to the digital howto wiki although I guess this is only
a problem if you update the nvidia driver.



More information about the mythtv-users mailing list