[mythtv-users] I killed XvMC with a little test. Help!

jb17bsome at bellsouth.net jb17bsome at bellsouth.net
Thu Feb 12 05:27:41 UTC 2009

On Wed, 11 Feb 2009 20:45:00 -0800
Allen Edwards <allen.p.edwards at gmail.com> wrote:

> My aux FE was just fine when and ran envyng to updage the nvidia
> driver. Now any recorded show that requires XvMC to play (HD shows)
> takes mythfrontend to 100% and a black screen with mythfrontend
> locked up. mythfrontend.log shows this as the last thing:
> 2009-02-11 20:20:22.115 TV: Changing from None to WatchingPreRecorded
> 2009-02-11 20:20:22.120 Failed to approve 'none' deinterlacer
> 2009-02-11 20:20:22.121 Couldn't load deinterlace filter
> 2009-02-11 20:20:22.121 Realtime priority would require SUID as root.
> 2009-02-11 20:20:22.143 XvMC: picture structure FRAME
> If I change from CPU--, which uses XvMC to SLIM, the show will play
> but not smoothly so it is unwatchable.  Thus it isn't the recording.
> I have tried several recordings.  SD recordings play fine.  You will
> notice from the log that I turned deinterlacing to "none" to simplify
> the problem.  It didn't help.  I tried putting in a new video card, a
> 5200 and updated the driver again and it acts the same.  I removed
> the driver and used the nvidia-xconfig to install it and it acts the
> same.  Nothing helps.
> P4 2.4GHz
> Nvidia 5200 AGP
> RGB monitor
> Mythbuntu 8.04
> branches/release-0-21-fixes version 19878
> I don't know what happened.  I was just trying to verify some things
> for the wiki I am writing and now my system is broken.
> I posted some of this within another thread but thought it better to
> start a new one.
> Allen

What does mplayer do?
mplayer -vo xvmc -vc ffmpeg12mc -ao null somefile.mpg

Does the cpu go to 100%?

If so then try disabling agp in your xorg.conf:
Option "NvAGP" "0"

More information about the mythtv-users mailing list