[mythtv-users] Issue with Mythweb and streaming music

Bob Sully rcs at malibyte.net
Sat Feb 7 03:38:04 UTC 2009

Chris Petersen wrote:

> Bob Sully wrote:
>> I just tried to stream some mp3 files from my mythbox tonight - I'm away
>> from home on vacation.  I can create playlists, but when I hit "play", I
>> get the "no input plugin" reply from Amarok.  I have also tried it using
>> a
>> friend's Windoze machine.  After asking for the credentials on the
>> Mythbox, it gets a message saying that Windows Media Player cannot
>> access
>> the server.
> Open up the m3u file you get from mythweb and make sure that it's using
> a server IP address that makes sense.  If so, try accessing the URL
> directly with your browser to see if you get a better error message.
> -Chris

Thanks, Chris.  I did that.  Here's what's in the .m3u file:

#EXTINF:159,Led Zeppelin - Living Loving Maid
#EXTINF:145,Led Zeppelin - Immigrant Song
#EXTINF:481,Led Zeppelin - Stairway to Heaven

(xxxx is the high-order port I'm using on the firewall, which translates
to port 80 on the Myth box).

I dropped one of those URLs into Firefox, and mplayer came up and played
the song without a problem.  Apparently it's an Amarok issue.

On my old laptop I was using Kubuntu 7.04 32-bit and xmms to play the
streams - worked fine.  This one's using Kubuntu 8.10 64-bit, and I don't
really care for the new version of xmms (xmms2), so tried using Amarok. 
Perhaps there's a better way?

Bob Sully - Simi Valley, California, USA

More information about the mythtv-users mailing list