[mythtv-users] Updated from fedora 10 to 12 and have issues with nvidia driver loading

Niels Dybdahl ndylist at gmail.com
Tue Dec 29 23:46:44 UTC 2009

On Fri, Nov 27, 2009 at 6:14 PM, Axel Thimm <Axel.Thimm at atrpms.net> wrote:

> Hi,
> On Thu, Nov 26, 2009 at 10:17:12PM -0500, Jarod Wilson wrote:
> > >>>>As many pointed out, adding "nouveau.modeset=0" at the end of
> > >>>>the kernel line in grub.conf is the solution.
> > >>>
> > >>>Its not. And nouveau.modeset=0 isn't strictly required. If you
> > >>>have the nouveau module blacklisted, a newly built initrd won't
> > >>>include the nouveau module, and you can boot w/o any extra
> > >>>params.
> > >>
> > >>I have this stanza in /etc/modprobe.d/blacklist.conf: blacklist
> > >>nouveau
> > >>
> > >>That did not help me until I actually added the kernel parameter
> > >>in grub.conf.  I did reboot.
> > >Same here..I had to recompile the kernel (initrd) without
> > >rivafb/nvidiafb and then the Nvidia driver started to work
> >
> > Um. Just for the record, building a new initrd is nothing even
> > *close* to "recompile the kernel". A new initrd is just a compressed
> > image of stuff that is either scripts or already compiled.
> > Recompiling the kernel involves building a new kernel from source
> > code. Very very different things.
> Just as a mini-howto: If one wants to rebuild the initrd for a
> packaged kernel and make sure it is done exactly the same way the
> Fedora/RHEL/etc. package did it, just look at the new-kernel-pkg of
> rpm -q --qf '%{postin}\n' kernel gives, for example
> [...]
> /sbin/new-kernel-pkg --package kernel --mkinitrd --dracut --depmod
> --install || exit $?
> [...]
> Copy and paste this into your root's console. It does the mkinitrd and
> other stuff.

I tried the mentioned method of using adding a blacklist nouveau and running
new-kernel-pkg on a new mythtv 0.22+Fedora 12+atrpms system. It did prevent
the nouveau driver from being loaded, but for some unknown reason, the
nvidia driver did not try to load at all. Earlier, before using the
"minihowto", the nvidia driver tried to load but failed due to the nouveau

I have reinstalled and tried the nouveau.modeset=0 and that just works

Inbetween I tried out Mythbuntu. It was easier to make the Nvidia driver run
(but not without bugs) (no need to disable any nouveau driver) but mythtv
did crash on updating my database scheme, so I went back to atrpms again
where the database scheme upgrade went smoothly.

Niels Dybdahl
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://mythtv.org/pipermail/mythtv-users/attachments/20091230/7bfa3815/attachment.htm>

More information about the mythtv-users mailing list