[mythtv-users] Firewire DCX3400 Support?

Andrew mythtv at heathsworld.com
Sat Dec 26 23:23:40 UTC 2009

On Thu, Dec 24, 2009 at 6:18 PM, Rod Smith <mythtv at rodsbooks.com> wrote:

> On Thursday 24 December 2009 04:57:54 pm Ken Mandelberg wrote:
> > Just swapped my Comcast DCH3400 for a newer DCX3400. I see an entry for
> > DCX3200 but not 3400 in the myth setup menu.
> >
> > Is there any info on getting the 3400 to work over firewire?
> >
> > I'm running the trunk.
> You might be able to get it to work with another setting. When I set up my
> DCX3200-M in MythTV 0.21, there was no matching setting in the setup menu.
> I
> selected whatever seemed closest at the time and then told Myth to use an
> external channel-change script. This script in turn called a modified
> version
> of the 6200ch program, the source code for which ships with MythTV. I just
> needed to add some FireWire IDs to the source code so that the program
> would
> recognize my cable box. This worked fine, and in fact I've not tried doing
> anything else with 0.22.
> --
> Rod Smith
> _______________________________________________
> mythtv-users mailing list
> mythtv-users at mythtv.org
> http://mythtv.org/cgi-bin/mailman/listinfo/mythtv-users

Ubuntu 9.10
Mythtv .22 fixes

I also have a DCX3400 that shows as a DCX3425 in the actual software menu on
the cable box.  I am trying to get mine to work via firewire as well.  I
tried about all the settings available in mythtv-setup and have not been
able to get the video stream to work yet.  It does detect it so that is
promising.  Does anyone have a working setup with this device that they can
share for us?

For the channel changing script: Can you please elaborate on adding Firewire
IDs?  I tried adding in:

#define DCT3425_VENDOR_ID1 0x00002210
#define DCT3425_MODEL_ID1 0x0000e726

to the 6200ch.c and recompiling but still get the same error or:

$ sudo ./6200ch -n 0 -v 802
starting with node: 0
node 0: vendor_id = 0x00002210 model_id = 0x0000e726
node 1: vendor_id = 0x00001e8c model_id = 0x00000000
Could not find Motorola DCT-6200 on the 1394 bus.

$ plugreport
Host Adapter 0

Node 0 GUID 0x002210fffe4a7b9b
oMPR n_plugs=1, data_rate=2, bcast_channel=63
oPCR[0] online=1, bcast_connection=0, n_p2p_connections=0
  channel=0, data_rate=2, overhead_id=0, payload=376
iMPR n_plugs=0, data_rate=2

Node 1 GUID 0x001e8c0001e1950c
libiec61883 error: error reading oMPR
libiec61883 error: error reading iMPR

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://mythtv.org/pipermail/mythtv-users/attachments/20091226/b8812dff/attachment.htm>

More information about the mythtv-users mailing list