[mythtv-users] Mythbuntu 9.10 / Myth .22 and Hauppauge HVR-1200 Mpeg Encoder fails(shud be HVR-1600)

Larry J on his Dell LT larry at foxgulch.com
Thu Dec 24 13:57:01 UTC 2009

Robert Rust wrote:
>> I have been chasing a problem with my latest myth installation.  I
>> recently installed Mythbuntu 9.10 and MythTV .22 over my previously
>> working  8.10 / .21 version.
>> I have a Hauppauge HVR-1600 Tuner/Mpeg encoder card installed which
>> worked great in my previous install. It is connected to an outside
>> antenna and to the S-video out of my Dish Satellite Receiver.  The ATSC
>> tuner/DVB  half functions OK but the s-video mpeg encoder output
>> (/dev/video0) shows a black screen in myth frontend "watch tv"  and a
>> red screen in VLC. When I request that a program be recorded from the
>> Dish receiver,  I get 30 minutes of red screen along with the Dish
>> receiver audio when I "play it" back in Myth.
>> 1.  I though perhaps I had a broken/bad s-video cable.  So I unplugged
>> the s-video cable from the HVR-1600 s-video jack and plugged it into the
>> Sony LCD TV. Picture fine.  Normal picture on all Dish channels.
>> 2. I though I must have mis-configured something in Myth.  So I fired up
>> VLC and chose Media, Capture Device, PVR and entered /dev/video0.
>> Red picture in VLC  with audio from the Dish Receiver, same as my
>> recordings. Certainly not
>> the picture I was expecting from the Satellite Receiver but at least the
>> Satellite audio was there.  In VLC, Media Information,  Codec Details
>> shows  Stream 0, type: Video, Codec: mpgv, Resolution: 720x480, Display
>> Resolution: 720x480, and Frame rate 29.970029.
>> 3. At this point, I think that the HVR-1600 analog section didn't
>> initialize correctly.   But the DVB half did and plays  OK in VLC.
>> Plus  it appears that the cx18 chip was initialized as shown below in
>> the following:
>> dmesg | grep cx18
>> [    5.540246] cx18:  Start initialization, version 1.2.0
>> [    5.540279] cx18-0: Initializing card 0
>> [    5.540281] cx18-0: Autodetected Hauppauge card
>> [    5.543479] cx18 0000:05:02.0: PCI INT A -> GSI 18 (level, low) -> IRQ
>> 18
>> [    5.543488] cx18-0: Unreasonably low latency timer, setting to 64
>> (was 32)
>> [    5.544762] cx18-0: cx23418 revision 01010000 (B)
>> [    5.761818] cx18-0: Autodetected Hauppauge HVR-1600
>> [    5.761820] cx18-0: Simultaneous Digital and Analog TV capture
>> supported
>> [    5.856928] IRQ 18/cx18-0: IRQF_DISABLED is not guaranteed on shared
>> IRQs
>> [    7.004368] tuner 1-0043: chip found @ 0x86 (cx18 i2c driver #0-1)
>> [    7.016646] tuner 1-0061: chip found @ 0xc2 (cx18 i2c driver #0-1)
>> [    7.209622] cs5345 0-004c: chip found @ 0x98 (cx18 i2c driver #0-0)
>> [    7.225253] cx18-0: Registered device video0 for encoder MPEG (64 x
>> 32 kB)
>> DVB initialization details omitted.
>> [    7.446209] cx18-0: Initialized card: Hauppauge HVR-1600
>> [    7.446229] cx18:  End initialization
>> [    7.488574] cx18 0000:05:02.0: firmware: requesting v4l-cx23418-cpu.fw
>> [    8.215916] cx18-0: loaded v4l-cx23418-cpu.fw firmware (158332 bytes)
>> [    8.243487] cx18 0000:05:02.0: firmware: requesting v4l-cx23418-apu.fw
>> [    8.507505] cx18-0: loaded v4l-cx23418-apu.fw firmware V00120000
>> (141200 bytes)
>> [    8.513677] cx18-0: FW version: (Release 2007/03/12)
>> [    8.720131] cx18 0000:05:02.0: firmware: requesting v4l-cx23418-cpu.fw
>> [    8.854592] cx18 0000:05:02.0: firmware: requesting v4l-cx23418-apu.fw
>> [    9.165685] cx18 0000:05:02.0: firmware: requesting v4l-cx23418-dig.fw
>> [    9.421104] cx18-0 843: loaded v4l-cx23418-dig.fw firmware (16382
>> bytes)
>> [    9.440302] cx18-0 843: verified load of v4l-cx23418-dig.fw firmware
>> (16382 bytes)
>> 4.  The version installed is
>> lj at mythtv:~/Desktop$ mythbackend --version
>> Please include all output in bug reports.
>> MythTV Version   : 22994
>> MythTV Branch    : branches/release-0-22-fixes
>> Network Protocol : 50
>> Library API      : 0.22.20091023-1
>> QT Version       : 4.5.2
>> Options compiled in:
>>  linux profile using_oss using_alsa using_pulse using_jack using_backend
>> using_dvb using_firewire using_frontend using_glx_proc_addr_arb
>> using_hdhomerun using_hdpvr using_iptv using_ivtv using_joystick_menu
>> using_libfftw3 using_lirc using_mheg using_opengl_video
>> using_opengl_vsync using_qtwebkit using_v4l using_x11 using_xrandr
>> using_xv using_xvmc using_xvmc_vld using_xvmcw using_bindings_perl
>> using_bindings_python using_opengl using_vdpau using_ffmpeg_threads
>> using_libavc_5_3 using_live using_mheg
>> lj at mythtv:~/Desktop$ uname -a
>> Linux mythtv 2.6.31-16-generic-pae #53-Ubuntu SMP Tue Dec 8 05:20:21 UTC
>> 2009 i686 GNU/Linux
>> 5. In my old installtion of Myth .21 and Mythbuntu 8.10 I
>> had installed the gnome-desktop.  As I said, that installation
>> worked perfectly with the HVR-1600.  I can't see why this
>> would cause a problem.
>> 6. In the synaptic repositories, I have checked
>> http://us.autobuilds.mythbuntu.org/mythbuntu/trunk-0.22/ubuntu
>> so I think I'm getting the latest updates.
>> A.  Any suggestions on what to try next?
>> B.  Does anyone out there have a HVR-1600 Myth.22/Mythbuntu 9.10
>> system working?  (I'd like to compare notes.)
>> Thank you,
>> Larry
> My HVR-1600 is sorta working on Mythtbuntu 9.10.  I tried the tuner and
> wasn't happy with the audio issues and didn't want to deal with building
> the driver myself.  I am wondering if you may have any ideas for me?  I
> have a working PVR-150 in the box and would like to set up the HVR-1600 to
> record S-video input.  The video recording works, but I don't know how to
> grab the audio that goes with it?  Any suggestions?  If you have any
> questions about my setup details, I'd be happy to provide answers.
> -Robert

What comes out of your properly configured HVR-1600 at  /dev/video0 
(typically depending on how many capture boards,  it may be /dev/video1 
or /dev/video2)  is an mpeg stream.  All mixed together in the stream is 
the audio and video program material. So no external audio 1/8 inch 
stereo cables are necessary.

As I've suggested,  you can test to see if your HVR-1600 properly 
initialized by starting VLC.  For example, on my HVR-1600,  VLC   
Media->Capture Device->PVR (in the drop down)-> /dev/video0 (for the 
device name)  then click play.

 If VLC refuses to start (no picture, no audio) make sure that the 
mythbackend isn't recording using /dev/video0.  The backend hogs this 
/dev/video0 stream (when a recording is called for) .  No " /dev/video0" 
in use error message, no nothing.  VLC  just doesn't start.  I've 
installed mythtv-status so I can tell whether the backend is sucking fom 
/dev/video0.  Maybe a good idea to stop the backend first!

A little bit of progress to report.   I did a "sudo service 
mythtv-backend stop" followed by "sudo modprobe -r cx18"  followed by 
"sudo modprobe  cx18" and finally "sudo service mythtv-backend start".  
Miraculously, the HVR-1600 mpeg encoder  now runs.  I can make 
recordings and see the mpeg stream in vlc.  Watch TV still doesn't work 
but I don't care about that.  The down side is along with my "sudo" 
incantations,  I also changed MANY other things.  I don't have a clue as 
to which one fixed my  "no output from /dev/video0"  Worse yet, since I 
spent several days researching and praying over this problem,  I very 
reluctant to touch anything!  I guess the rule with Mythtv is if it's 
working,  just be grateful.  


More information about the mythtv-users mailing list