[mythtv-users] FF h.264 files using Internal Player

Taylor Ralph tralph11 at yahoo.com
Wed Dec 23 16:32:46 UTC 2009

--- On Wed, 12/23/09, James Oltman <cnlibmyth at gmail.com> wrote:

> From: James Oltman <cnlibmyth at gmail.com>
> Subject: [mythtv-users] FF h.264 files using Internal Player
> To: "Discussion about mythtv" <mythtv-users at mythtv.org>
> Date: Wednesday, December 23, 2009, 9:58 AM
> I've moved over to the internal player
> (was using mplayer) for playing h.264 files.  I like having
> the OSD.  When I fast forward through the file, it is not
> as smooth as with a recorded MPEG2 file (from HDHR for
> example).  Obviously, they are different file types, but I
> was hoping it would FF smoother.  Also, I get audio from
> the program that doesn't seem to FF at the same rate as
> the video FFs.  (It's strange that I never have audio
> playing from MPEG2 files while FFing using INTERNAL
> player)  So the audio is playing at normal speed but
> breaking up (not really skipping ahead) and the video is
> very choppy.  MPlayer was much smoother and simply jumped
> ahead the specified number of seconds I have configured. 
> If that's the way it is, then I'm fine with that, I
> was just curious more than anything.  I'm running
> Mythbuntu x64 9.10, MythTV .22, nVidia 9500GT (512MB) PCIe
> 16x, w/ JYA's repo and latest nVidia
> drivers(195.something?).  MythTV is configured for the
> "Seperate Video Modes" @ 1920x1080.  Thanks!
> Jim

If you are willing to compile then you can try a patch that improves libavf seeking when using the Internal player.


You'll also want to apply another patch to fix the video corruption problem when seeking in MKV containers.


If you do try this it'd be nice to here how your experience goes.



More information about the mythtv-users mailing list