[mythtv-users] trouble scanning for channels

Jack Andrews jack at andrewsmail.co.uk
Mon Dec 21 14:02:17 UTC 2009


This is my first ever mailing list post, so please go easy on me!  I 
hope this is the correct place to ask for mythTV support... if it isn't, 
please could someone redirect me!

My problem:
I live in the UK and I'm trying to pick up DVB-T channels with MythTV 
0.22.  I've tried using a full scan and it finds about about 5 channels 
(QVC, ITV3... nothing I want!).  So I tried the method I used previously:
$ scan -a0 -o zap /usr/share/dvb/dvb-t/uk-TheWrekin > channels.conf

This picks up all the channels I want.  However, when trying to 'Import 
channels.conf' no channels appear.  Furthermore mythTV finds no channels 
when I tried a tuned scan using the exact multiplex settings found in 

This reminded me of an issue I had last time I tried mythTV (0.21)... 
sadly the details are a little sketchy as it was some time ago!  I 
managed to import the channels from channels.conf but then I couldn't 
get a lock when trying to watch TV.  It turned out that mythTV was 
getting confused over which multiplex to use and I had to manually fix 
the values in the database (if memory serves, column 'mplexid' was one 
to small and everything was fixed with 'UPDATE channel SET mplexid = 

It seems as if the behaviour of mythTV 0.21 was to blindly add 
channels.conf to the database, whilst 0.22 checks each channel in 
channels.conf exists and can be locked.  Could myth still be getting 
mixed up over the which multiplex to use for which channel and hence 
rejecting every channel in channels.conf?

My tuner is: KWorld DVB-T 220RF

Any suggestions would be greatly appreciated.



More information about the mythtv-users mailing list