[mythtv-users] Automatically running Mythfilldatabase

Michael T. Dean mtdean at thirdcontact.com
Sun Dec 20 03:16:19 UTC 2009

On 12/19/2009 03:26 PM, Phil Bridges wrote:
> On Fri, Dec 18, 2009 at 11:29 AM, Phil Bridges wrote:
>> On Fri, Dec 18, 2009 at 11:22 AM, Patrick Oglesby wrote:
>>> On Fri, Dec 18, 2009 at 8:19 AM, Phil Bridges wrote:
>>>> Does anybody have any suggestions on where to look to debug why
>>>> mythfilldatabase isn't automatically being run?  The option is set,
>>>> and is supposed to be run at SchedulesDirect's suggested time, but
>>>> nothing is happening.  Mythweb doesn't show "Next scheduled time".
>>>> This is on a new .22 install.
>>> Did you try running it once manually after setup?  Try running it once
>>> by yourself and see if it picks up another time to run.
>> Yep.  In fact, I just ran it, and my MythWeb status page says:
>> Last mythfilldatabase run started on 2009-12-18 11:11 and ended on
>> 2009-12-18 11:11. Successful.
>> There's guide data until 2010-01-01 06:00 (14 days).
>> DataDirect Status: Your subscription expires on Sun Jun 20 (2010) 10:28 PM
>> I'd rather follow SD's wishes and use their suggested time, but I may
>> have to put it in a cron job.
> Anybody have any suggestions?

For now, restart all of your mythtv system (shut down all frontends, all 
remote backends, and then the master backend and then restart).

Someone reported a similar issue and basically said, "Myth thought it 
was still running mythfilldatabase, so it didn't try again."  He never 
explained what he meant by that, but the only place I see where Myth 
records that it's currently running mythfilldatabase is an in-memory 
variable, so it should be fixed by a restart.

If not, figure out where it's storing that it's still running mfdb, and 
I'll fix it for you.


More information about the mythtv-users mailing list