[mythtv-users] Gentoo / Jamu?

Phil Bridges gravityhammer at gmail.com
Fri Dec 18 19:30:46 UTC 2009

Did any of you Gentoo users have to do any changes to get Jamu to
work?  I ran into problems at first that were solved by emerging the
Python element trees.  Now, I run this:

jamu.py -l en -C ~/.mythtv/jamu.conf -MIV

and get this:

! Warning - The module xml (v41660 or greater) must be installed. Your
version is different (v0.8.4) than what Jamu was tested with. Jamu may
not work on your installation.
It is recommended that you upgrade.

Traceback (most recent call last):
  File "/usr/share/mythtv/mythvideo/scripts/jamu.py", line 6434, in <module>
  File "/usr/share/mythtv/mythvideo/scripts/jamu.py", line 6415, in main
  File "/usr/share/mythtv/mythvideo/scripts/jamu.py", line 1845, in
  File "/usr/share/mythtv/mythvideo/scripts/jamu.py", line 1600, in
    sys.stderr.write(u"\n! Warning: MythTV (%s) directory (%s) does
not exist.\n" % (key, tmp_directories[i]))
UnboundLocalError: local variable 'tmp_directories' referenced before assignment

I couldn't find anything under the wiki to answer this.  Any suggestions?

More information about the mythtv-users mailing list