[mythtv-users] NewEgg Cheap Nvidia GT220 Cards

backuppc at sundquist.imapmail.org backuppc at sundquist.imapmail.org
Fri Dec 18 04:29:01 UTC 2009

Richard wrote:

> NVIDIA-package.run --uninstall 

That worked.  I got the old 8.04 working again with the old 169 drivers
that came with 8.04  So that takes care of "the ugly"

But on to the new card...

Ron wrote:

> The bad and ugly parts are unfortunate, but as you suggest I'm not
> convinced they have anything to do with this card directly. Have you
> tried to see what deinterlacers you can get with 1080i content
> (although the wiki says no for Advanced 2x, I thought I recall reading
> something suggesting it MIGHT be possible with the card).
> Anyway, I've been holding off on buying this card for a few weeks now
> (I like the low power consumption and fanless design). Maybe it's time
> I go ahead and place the order. 

I can't really get to play around with the new card until I get it to
work in the old install (which I need to keep around for WAF reasons
until the new setup is OK).

But I can't get the G210 to work on 8.04.  I realize I need the 190
driver, and installed it after adding
http://ppa.launchpad.net/nvidia-vdpau/ppa/ubuntu hardy main to my
sources list.

It installs over the old 169 OK, but my X logs just say:

(EE) Failed to initialize GLX extension (Compatible NVIDIA X driver not

It seemed to install OK:

user at mythtv:~$ dpkg -l | grep nvidia
ii  dkms                                                        Dynamic
Kernel Module Support Framework
ii  nvidia-190-kernel-source                  
190.53-0ubuntu1~karmic~nvidiavdpauppa6                     NVIDIA binary
kernel module source
ii  nvidia-190-modaliases                     
190.53-0ubuntu1~karmic~nvidiavdpauppa6                     Modaliases
for the NVIDIA binary X.Org drive
ii  nvidia-glx-190                            
190.53-0ubuntu1~karmic~nvidiavdpauppa6                     NVIDIA binary
Xorg driver
rc  nvidia-glx-195                            
195.22-0ubuntu1~karmic~nvidiavdpauppa2                     NVIDIA binary
Xorg driver
rc  nvidia-glx-new                             169.12+    
                                 NVIDIA binary XFree86 4.x/X.Org 'new'
ii  nvidia-kernel-common                       20051028+1ubuntu8        
                                 NVIDIA binary kernel module common
rc  nvidia-settings                            1.0+20080304-0ubuntu1.1  
                                 Tool of configuring the NVIDIA graphics
ii  nvidia-settings-190                       
190.42-0ubuntu1~karmic~nvidiavdpauppa1                     Tool of
configuring the NVIDIA graphics driv

What's interesting is that these package names say karmic in them, even
though I added the hardy repo.  Strange, but they load into the kernel,
so it should be OK:

user at mythtv:~$ lsmod | grep nvidia
nvidia               4718832  0
i2c_core               24832  13
agpgart                34760  2 nvidia,intel_agp

Perhaps it is because the motherboard isn't recognizing it as a G210?:

user at mythtv:~$ lspci | grep nVidia
01:00.0 VGA compatible controller: nVidia Corporation Unknown device
0a65 (rev a2)
01:00.1 Audio device: nVidia Corporation Unknown device 0be3 (rev a1)

It just says "Unknown device"

But when I boot into 9.10, lspci says:

01:00.0 VGA compatible controller: nVidia Corporation GT200 [GeForce
210] (rev a2)
01:00.1 Audio device: nVidia Corporation Device 0be3 (rev a1)

So it recognizes it there.  

That is probably the problem.

Why would the motherboard recognize the card running 9.10 but not 8.04?

Sorry none of this is mythtv-related, but if I get this figured out, I
can leave the card in the box and start doing testing of the card with

Jon S.

More information about the mythtv-users mailing list