[mythtv-users] Need database upgrade help

Phil Bridges gravityhammer at gmail.com
Sun Dec 13 20:23:12 UTC 2009

On Sun, Dec 13, 2009 at 2:20 PM, Phil Bridges <gravityhammer at gmail.com> wrote:
> Hello, all.
> I'm in the weekend-long process of upgrading my two backends and four
> frontends (all on Gentoo).  I backed up my database following the
> directions: http://www.mythtv.org/wiki/Fixing_Corrupt_Database_Encoding
> After getting the backend updated to .22, I started to restore my
> database, but it didn't work.
> I managed to get my "to-uncorrupt" database loaded, but it gives
> faulty information.  It doesn't show recordings I've made in a *long*
> time.
> Here's my current mysql config (after I've updated to .22):
> mysql  Ver 14.12 Distrib 5.0.84, for pc-linux-gnu (x86_64) using readline 6.0
> Connection id:          106
> Current database:       mythconverg
> Current user:           mythtv at localhost
> SSL:                    Not in use
> Current pager:          stdout
> Using outfile:          ''
> Using delimiter:        ;
> Server version:         5.0.84 Gentoo Linux mysql-5.0.84-r1
> Protocol version:       10
> Connection:             Localhost via UNIX socket
> Server characterset:    utf8
> Db     characterset:    latin1
> Client characterset:    utf8
> Conn.  characterset:    utf8
> UNIX socket:            /var/run/mysqld/mysqld.sock
> Uptime:                 1 hour 44 min 24 sec
> How can I use my mythconverg-to_uncorrupt.sql that I made on the wiki
> page.  How can I get my information dumped back into my database in a
> form it can use?

Well, I've looked at every .sql file I have on my system, and it
appears that something screwy happened on my backup.  The only data I
have in my backup is from March of this year forward.  Looks like I'm
going to just delete all 4GB of recordings and start from scratch.
Very irritating.

Let this serve as a warning to everybody to confirm your backup is
correct after you use a backup script.

More information about the mythtv-users mailing list