[mythtv-users] database upgrade fail: schema 1160 to 1244

Jeff Bryner jeff at jeffbryner.com
Wed Dec 9 05:44:28 UTC 2009

> I'd feel more comfortable with the below if I could see the output  
> of: mythbackend --version

Here 'tis:

# mythbackend --version
Please include all output in bug reports.
MythTV Version   : 22860
MythTV Branch    :
Network Protocol : 50
Library API      : 0.22.20091023-1
QT Version       : 4.5.3
Options compiled in:
  linux profile using_oss using_alsa using_backend using_firewire  
using_frontend using_glx_proc_addr_arb using_hdhomerun using_hdpvr  
using_iptv using_ivtv using_joystick_menu using_lirc using_mheg  
using_opengl_video using_opengl_vsync using_qtwebkit using_v4l  
using_x11 using_xrandr using_xv using_xvmc using_xvmcw  
using_bindings_perl using_bindings_python using_opengl  
using_ffmpeg_threads using_libavc_5_3 using_live using_mheg

Seems to match no?

> If you do, in fact, have a sufficiently-new version of MythTV, then  
> it's the invalid UTF-8 connection causing the issues, so when you  
> fix the database (both the database server configuration and the  
> database data) with  
> http://www.mythtv.org/wiki/Fixing_Corrupt_Database_Encoding , it  
> will work.

OK, here I go..I've got good backups so I can always restore..or just  
start again.

Thanks again,


More information about the mythtv-users mailing list