[mythtv-users] database upgrade fail: schema 1160 to 1244

Jeff Bryner jeff at jeffbryner.com
Wed Dec 9 05:26:17 UTC 2009

Thanks for the quick response:

> No, the problem is that you're using an old version of 0.22-fixes  
> (or 0.22 release tarball).  You need to update to current 0.22-fixes  
> (at least r22550).

Looks like I've got a good version? The latest in gentoo/portage is:
mythtv-0.22_p22860 which is what I have just installed. Lemme know if  
I should grab something specific from the trunk or just go for a  
non-portage install.

The mysql status dump is the current mysql which was also updated in  
the emerge -avu world. I wasn't smart enough to copy the old config,  
so I'll have to assume I'm in the camp with the bad config.

> You should a) upgrade to current 0.22-fixes, and b) go back to the  
> 0.20 backup and try  
> http://www.mythtv.org/wiki/Fixing_Corrupt_Database_Encoding .

OK, I've been studying it and will give it a go.

Thanks again,


More information about the mythtv-users mailing list