[mythtv-users] Mythweb "Unknown video type requested" - MKV only

B. Rosenstock barry253 at gmail.com
Mon Dec 7 23:23:18 UTC 2009

On Mon, Dec 7, 2009 at 6:12 PM, B. Rosenstock <barry253 at gmail.com> wrote:
> Running Mythtv 0.22-fixes on Ubuntu Karmic as combined FE/BE.
> I am trying to troubleshoot a set of MKV files that I have (old Mister
> Rogers episodes). None will stream or "direct download" from Mythweb.
> All other filetypes do flash streaming appropriately; the mkv files
> launch flowplayer and then just show a black screen.  Clicking direct
> download gives the following error:
> "Unknown video type requested: Mister Rogers' Neighborhood - 29x09 -
> Go-Stop-Go (x264,AC3).mkv"

Sorry, don't know why the rest of my email was truncated.


The files play back fine locally in the FE.

I tried recompiling ffmpeg with all options, no change:
 built on Dec  1 2009 15:37:42 with gcc 4.4.1
  configuration: --enable-gpl --enable-version3 --enable-nonfree
--enable-pthreads --enable-libfaac --enable-libfaad
--enable-libmp3lame --enable-libopencore-amrnb
--enable-libopencore-amrwb --enable-libx264 --enable-libxvid
--enable-x11grab --disable-vdpau

Mencoder reports the following on the files:
MEncoder SVN-r29973-4.3.4 (C) 2000-2009 MPlayer Team
success: format: 0  data: 0x0 - 0xd48949c
[mkv] Track ID 1: video (V_MPEG4/ISO/AVC), -vid 0
[mkv] Track ID 2: audio (A_AAC), -aid 0, -alang und
[mkv] Will play video track 1.
Matroska file format detected.
VIDEO:  [avc1]  640x480  24bpp  29.970 fps    0.0 kbps ( 0.0 kbyte/s)
[V] filefmt:31  fourcc:0x31637661  size:640x480  fps:29.970  ftime:=0.0334
videocodec: framecopy (640x480 24bpp fourcc=31637661)

The files streamed fine in 0.21 (before Karmic, as well).

Any advice or troubleshooting steps?


More information about the mythtv-users mailing list