[mythtv-users] QT Issues

Fedor Pikus fpikus at gmail.com
Mon Dec 7 06:11:26 UTC 2009

On Sun, Dec 6, 2009 at 6:54 PM, Rod Smith <mythtv at rodsbooks.com> wrote:
> On Sunday 06 December 2009 08:53:47 pm Fedor Pikus wrote:
>> On Sun, Dec 6, 2009 at 5:43 PM, Joe Wilson <wilson.joe at gmail.com> wrote:
>> >    I have been using OpenGL instead of QT..  Is there a serious
>> > difference between the two?
>> For me, there was: GL painter worked but there was about 1 second
>> delay before MythTv would respond (and I don't meed complex things, a
>> second would pass between pressing down arrow and frontend selecting
>> the next menu entry). With QT painter the response is instant.
> My experience is similar, but not identical: For me, OpenGL results in delays
> as the system paints images. It looks like OpenGL is trying to create smooth

Well, I can't be sure what's causing the delay. May be it's the system
changing the picture corresponding to the menu entry selected, and not
the menu selection itself. Either way it manifests itself as I press
the arrow key, nothing happens for about a second, then the next menu
line is highlighted and the picture on the right of the menu changes.

> "fade" transitions rather than the abrupt "cuts" that Qt produces. These
> delays are most noticeable when switching screens. I don't recall big delays
> when just moving from item to item in a screen -- but I might have missed
> that, since I only played with the OpenGL renderer briefly, since I prefer
> quick transitions to smooth fades in menus, anyhow.
> --
> Rod Smith
> _______________________________________________
> mythtv-users mailing list
> mythtv-users at mythtv.org
> http://mythtv.org/cgi-bin/mailman/listinfo/mythtv-users

Fedor G Pikus (fpikus at gmail.com)

More information about the mythtv-users mailing list