[mythtv-users] mythfrontend almost unusable when mythbackend recording and comflagging

Jim Stichnoth stichnot at gmail.com
Mon Dec 7 04:03:38 UTC 2009

On Sun, Dec 6, 2009 at 2:43 PM, John Nissley <jnissley at nissley.org> wrote:
> Two mythtv frontend / backend combination boxes and one stand alone
> frontend.
> I am running trunk and have noticed within the last few weeks I have been
> having problems with my frontends listing available recordings on the
> backends mostly when the backends are recording and commflagging.  When this
> problem occurs I notice that the mythbackend process is consuming 5 times
> more CPU than during normal operation.  The back end CPU's are dual core and
> 2.4 GHz or better.  When this occurs the only way to get video listings from
> the backend is to restart the backend.  After the backend is restarted CPU
> utilization returns to normal and listing of the available recordings is
> possible again.
> Is there anything I can try or any data I can provide to help find and
> resolve this problem?

I wonder if this is the same problem I noted in
http://www.gossamer-threads.com/lists/mythtv/users/411648 .
Specifically, during a recording, filesize updates are sent out much
faster than they should be, and then program info updates are sent out
to the frontends faster than they can handle.  The only problem with
this theory is that my system running r22901 works just fine (r22949
has problems, but I don't have any other data points), and r22901 is
less then 2 weeks old, which doesn't really match the "within the last
few weeks" observation.


More information about the mythtv-users mailing list